我怎样才能更新纱线全球包?

我尝试了一些可能的CLI命令,但似乎没有实际更新与yarn global add安装的软件包。

yarn global upgradeyarn upgrade global都无法正常工作。 有没有办法升级全球软件包?

       

网上收集的解决方案 "我怎样才能更新纱线全球包?"

使用yarn global add <package>@latest将升级一个特定的包,如果这是你正在做的。

我正在使用yarn global upgrade

TL; DR:

正如Webjay所说 ,你只需:

 yarn global upgrade 

yarn版本1.2.1以上。

对于早期版本:

 (cd ~/.config/yarn/global && yarn upgrade) 

检查和修复

可悲的是,目前没有yarn global check

您可以运行yarn global add --force来重新安装所有软件包。

check全局包,你可以把~/.config/yarn/global/当作一个本地包,因为:

  • ~/.config/yarn/global/package.json对所有全局包都有依赖关系
  • ~/.config/yarn/global/node_modules包含了所有的全局包。

检查所有全局程序包,并仅在发现错误时重新安装:

 $ (cd ~/.config/yarn/global && yarn check || yarn install --force)