如何解决脚本错误:节点模块?

我尝试为我的Ionic应用程序使用Node.js的Mailjet Wrapper。

现在我尝试使用以下代码连接到邮件:

var connection = require(['node-mailjet'], function(mailjet){ mailjet.connect('api key', 'api secret'); }); 

但是我得到这个错误:

require.min.js:8未捕获错误:脚本错误:node-mailjet

有谁知道如何解决它? 我已经安装了require.js库。

       

网上收集的解决方案 "如何解决脚本错误:节点模块?"

查看您在此答案的评论中指定的错误的链接 。 这里你可以find你的解决scheme

这发生在有要求('名称')调用,但'名称'模块尚未加载。

可能是上面的语句发生在你的情况下,即当你试图使用它时, node-mailjet没有被加载。 (根据我已经search的评论中的错误)。