警告:运行“指南针:服务器”(指南针)任务

D:\Projects\mallspk>grunt serve Running "serve" task Running "clean:server" (clean) task >> 0 paths cleaned. Running "wiredep:app" (wiredep) task Running "wiredep:test" (wiredep) task Running "wiredep:sass" (wiredep) task Running "concurrent:server" (concurrent) task Warning: Running "compass:server" (compass) task Warning: Command failed: 'compass.bat' is not recognized as an internal or exter nal command, operable program or batch file. Use --force to continue. 

我已经安装了Yo angular并运行以下命令:

 npm install grunt --save-dev npm install -g grunt-contrib-compass npm install -g compass npm install bower install npm install grunt-google-cdn 

当我运行命令grunt serve我有这个错误。 我有最新的节点和npm安装最新的咕噜和

       

网上收集的解决方案 "警告:运行“指南针:服务器”(指南针)任务"

我有ruby安装@squiroid。 我忘了运行gem install compass 。 这对我有效。

我在Ubuntu的同样的问题,我做了这个来解决我的问题:

  1. sudo apt-get install ruby
  2. sudo apt-get install ruby-compass
  3. sudo gem install compass

之后, grunt serve工程

我有同样的问题,我在我的桌面上安装指南针gem,它已经解决。

如果你在OS X或者Linux上,你可能已经安装了Ruby; 用ruby -v在你的terminaltesting。 当你确认你已经安装了Ruby时,运行gem update –system && gem install compass来安装Compass和Sass。

对于Windows,你可以下载ruby ,然后安装指南针。

希望能帮助到你 :)

我有同样的问题

“哟angular”与sass选项将使用指南针,这是一个rubygem。

安装ruby和指南针

在Windows系统中,我们也需要设置ruby的path。 将ruby / bin添加到path

然后“咕噜咕噜”作品!

我search和搜查…直到最后我得到了这个问题的答案。
在我的情况下,当我用yeomen创build一个新的angularjs应用程序时就发生了这种情况。

这个答案是特定于Windows用户

第1步:安装ruby http://rubyinstaller.org/downloads/

第2步:下载rubygems链接: https ://rubygems.org/rubygems/rubygems-2.6.8.zip

第3步:解压缩rubygems-2.6.8.zip

第4步:打开PowerShell(terminal/命令行)到rubygems-2.6.8文件夹path(文件夹的位置,例如.c:\ folder \文件夹)

第5步:在PowerShellterminal中运行这些命令

 > ruby setup.rb > gem install compass 

请享用!

我也有这些问题,我发现通过设置源映射为false临时修复。

 server: { options: { sourcemap: false <-- } } 

之后,它就像魅力一样。

从grunt-contrib-compass的文件,那就是说:

“这个任务需要你安装Ruby,Sass和Compass> = 1.0.1”和“当你确认已经安装了Ruby时,运行gem update –system && gem install compass来安装Compass和Sass。

我遵循这个指示,并修正了警告。

如果你在使用node + express + Angluar的时候对Ruby有同样的奇怪感觉,运行“yo angular xyz”,但是用gulp代替grunt。