在4.0更新后从NodeJS得到“Segmentation fault:11”

我刚刚重新安装了NodeJS。 在重新安装之前,当我运行node -v我得到了一个类似“0.2.x”的版本号……这是一个奇怪的数字。 而且因为我今天早上读了Node,所以刚刚更新到4.xx版本我以为我应该更新它。 另外,我还有其他问题,所以我认为这可能是原因。

当我运行以下server.js我得到以下控制台打印出来。

server.js …

 var express = require('express'); var mongoose = require('mongoose'); var bodyParser = require('body-parser'); var methodOverride = require('method-override'); var _ = require('lodash'); // Create the application. var app = express(); // Add Middleware necessary for REST API's app.use(bodyParser.urlencoded({extended: true})); app.use(bodyParser.json()); app.use(methodOverride('X-HTTP-Method-Override')); // CORS Support app.use(function(req, res, next) { res.header('Access-Control-Allow-Origin', '*'); res.header('Access-Control-Allow-Methods', 'GET,PUT,POST,DELETE'); res.header('Access-Control-Allow-Headers', 'Content-Type'); next(); }); // Connect to MongoDB mongoose.connect('mongo connection string......'); mongoose.connection.once('open', function() { // Load the models. app.models = require('./models/index'); // Load the routes. var routes = require('./routes'); _.each(routes, function(controller, route) { app.use(route, controller(app, route)); }); console.log('Listening on port 3000...'); app.listen(3000); }); 

在运行node --debug server.js之后,控制台将打印以下内容

 Debugger listening on port 5858 Segmentation fault: 11 

编辑:我有另一个基于MEANJS的项目。 当我运行Gruntfile.js从控制台得到一个Segmentation fault: 11

编辑#2:我只是降级到节点v0.12.7,事情似乎正常工作…

       

网上收集的解决方案 "在4.0更新后从NodeJS得到“Segmentation fault:11”"

我相信你需要在node_modules重新安装一些本地lib,所以基本上可能需要删除node_modules ,并再次npm install

也可能需要在安装前运行npm cache clean

在删除node_modules然后再次运行npm install之前,请尝试npm rebuild 。 它将重新编译已安装的新版本的Node / V8的本机模块,而无需再次下载所有文件。

npm rebuild应该工作。 但是,如果没有,那么尝试删除node_modules并运行npm install作为核选项。