为什么有4个版本的Node JS?

为什么有(现在)四个“当前”版本的NodeJS?

  • 0.10.41(维护)
  • 0.12.9(LTS)
  • 4.2.3氩(LTS)
  • 5.1.1(稳定)

根据NodeJS 发布页面 ,所有这些都在12月3日发布。 但有什么区别? 我应该用哪个?

       

网上收集的解决方案 "为什么有4个版本的Node JS?"

LTS vs稳定

  • LTS(长期支持):成熟可靠。 久经考验的稳定性和承诺,保持这种方式。
  • 稳定:最新function。 可用于生产,但不build议那些不需要这些function和需要可靠性的用户。

NodeJS与IoJS

IoJS是NodeJS的一个分支,用于更新V8引擎并引入ES6支持。 这两个社区投票合并,现在IoJSfunction已经从9月份开始,以4开始。 版本格式如此剧烈变化的原因是因为他们采用了IoJS的semver的使用。 版本1到3是IoJS版本。 此时你可以或多或less地忽略IoJS。

正如我所提到的,4是最新的LTS版本,5是最新的Stable版本。

预IoJS

在合并之前,NodeJS 0.10是一个LTS,而0.12是稳定的。 现在,0.12是一个LTS,而0.10是一个旧版维护。 我对0.10的承诺没有任何事实或数字。

使用哪个

你应该考虑你的目标受众和你所拥有的环境。

如果您的环境允许NodeJS 4.x或更高版本(即,如果您的主机环境支持它),并且该版本上的依赖关系兼容性没有问题,则可以自由定位最新的LTS,如果您正在生产应用程序或模块那里的可靠性和稳定性是至高无上的,或者5,如果你需要或者可以接受最新最好的。 如果您与NodeJS 4或更高版本存在兼容性问题,请使用0.12。

更多信息 。

如何pipe理多个版本的NodeJS

您可能会遇到安装最新,最好的Node的问题,并且您的项目将无法工作,或者相反,您需要为某个项目安装较旧的版本,但希望将较新的版本用于另一个项目。

inputNVM ,这是一个bash实用程序,它允许您使用命令行安装和切换到不同的节点版本,或者将设置文件放入您的项目中,让它自动切换。 请注意,NVM只是Linux / OSX; 请参阅NVM自述文件以获取Windows兼容模拟器的列表。