电子不在树莓派上工作

目前,我正在为我的Raspberry Pi开发一个“信息亭”应用程序。 我决定使用Electron,因为它提供了我需要的关键function:将基于Web的UI与直接系统结合起来,通过node.js进行I / O访问。

但是,Electron拒绝在我的Raspberry Pi上运行,而在我用于开发的计算机上它工作得很好。 发行electron .后什么也没有发生 在terminal中,程序刚刚退出,没有显示窗口或命令行中的任何错误。 任何线索? 到目前为止,我在网上找不到任何东西。 我通过npm install electron-prebuilt -g安装了Electron,它下载并安装了最新的ARM版本。

如果这是一个无法解决的兼容性问题:电子有没有什么好的select?

提前致谢!

       

网上收集的解决方案 "电子不在树莓派上工作"

不幸的是,这个错误的原因是Electron目前不支持ARM设备。 我们将不得不等到实施

看到这个问题https://github.com/atom/electron/issues/1702

– 更新

正如@skeggse指出的,Electron现在支持ARM。

  • 1获取依赖apt-get install libgtk2.0-0 libnotify4 libgconf2-4 libnss3 node npm

  • 2从这里下载称为electron -…- linux-arm.zip的最新arm版本

  • 3 unzip electron-...-linux-arm.zip

  • 4进入文件夹并双击名为electron的文件

  • 5玩得开心!

根据你拥有的Raspberry Pi,它可能是一个不兼容的二进制文件。 电子预编译的二进制文件,我相信,目标armv7-hf。 尝试从源头build立电子。 说明可以在这里findhttps://github.com/atom/electron/blob/master/docs/development/build-instructions-linux.md

请注意,如果您有兴趣使用硬件浮点支持(至less在RPiB +之前),则可能需要运行Raspbian或另一个具有硬浮点支持的端口。 ( ref )

这是一个相当广泛的问题。 您可以尝试在应用程序的第一行停止:

 electron --debug-brk=5858 . 

这将帮助您确定是否是电子问题或您的应用程序的问题。

http://electron.atom.io/docs/v0.30.0/tutorial/debugging-main-process/

以用户pi的身份连接到Raspberry SSH,并执行此操作:

 # Clone this repository git clone https://github.com/electron/electron-quick-start # Go into the repository cd electron-quick-start # Install dependencies npm install # Set display export DISPLAY=:0 # Run the app npm start