Angular2应用程序安装&运行通过package.json可能?

我的问题与4天前提出的问题有关:(URL#1) 如何使用npm启动所需文件最less的Angular2项目?

我使用上面的URL中提到的package.json,我正在做同样的项目。 我得到以下错误,我认为解决scheme是:(URL#2) https://github.com/npm/npm/issues/8048

但是,我想要确认某个人已经正确识别了导致这些错误的问题。 我正在执行#URL2中的build议,看看我的问题是否消失。 我正在尝试这个(即“npm开始”命令)在Windows 7和Windows 10和获得错误在这两个操作系统。

为了您的利益,这里有详细的错误列表:错误Windows_NT 6.1.7601错误argv“C:\ Program Files \ nodejs \ node.exe”“C:\ Users \ dev4 \ AppData \ Roaming \ npm \ node_modules \ npm \ bin \ npm-cli.js“”start“错误npm v3.5.3错误代码ELIFECYCLE错误angular2-quickstart@1.0.0 start: concurrent "npm run tsc:w" "npm run lite"错误退出状态1错误在angular2失败-quickstart@1.0.0启动脚本“并发”npm run tsc:w“”npm run lite“”。 错误确保安装了最新版本的node.js和npm。 错误如果这样做,这很可能是angular2-quickstart软件包的一个问题,而不是npm本身的错误。 错误告诉作者,这在你的系统上失败:错误并发“npm run tsc:w”“npm run lite”错误你可以得到有关如何打开这个项目的问题的信息:error npm bugs angular2-quickstart error or if那是不可用的,你可以通过它得到他们的信息:错误npm所有者ls angular2-quickstart错误上面可能有额外的日志logging输出。 verbose exit [1,true]

感谢您的时间。

-Srikanth

       

网上收集的解决方案 "Angular2应用程序安装&运行通过package.json可能?"

我不确定你在第二个(github)链接中指的是什么解决scheme,除非你的意思是你在代理之后工作,并且设置http_proxy正确地解决了你的问题。

最近经历了这个,我是这样工作的。 我的版本供参考…

@> node -v

V5.4.1

@> npm -v

v3.3.12

我有问题更新到最新的TypeScript编译器。 不pipe我使用哪个npm命令,它都不会安装/更新我的系统版本(v1.0.3.0 – 从Visual Studio安装)。 另外,当我运行初始安装时, concurrentconcurrent节点包)和lite-server显然没有通过package.json安装。 我收到的错误是:

npm ERR! 代码SELF_SIGNED_CERT_IN_CHAIN

(Angular 2“入门指南”说忽略错误,所以我做了一段时间…)


解决SSL证书问题

由于这个证书,我终于意识到没有安装任何东西。 错误。 我碰到这个问题 ,并尝试了几个答案,但考虑到我的工作环境,我最终暂时允许使用HTTP而不是HTTPS,就像这样…

警告:请自行承担风险,如果使用此操作,请立即考虑将其设置为true

npm set strict-ssl false

但如果它适合你,我会build议使用已知的注册商通过…

npm config set ca=""


修复安装(已编辑)

然后,在解决SSL证书问题之后,您应该在angular2-quickstart目录中运行npm installnpm update如果已有的angular2-quickstart 。 这样做,你会注意到大部分的初始安装都会失败,包括安装其他的核心依赖(比如angular2 )。 我专注于开发环境本身(打字稿,精简版服务器等),并完全忽略了应用程序本身的这些库从未安装的事实。


留下这个参考…

如果你想明确地安装/更新package.json devDependency部分列出的软件包,你可以运行…

 npm install -g concurrently typescript lite-sever 

感谢这个答案 ,帮助我实现concurrent程序的包concurrent调用。


最新的TypeScript编译器(已编辑)

我最初提到了引用TypesSript v1.7.3的package.json ,但它引用了^1.7.3或“> = 1.7.3”,所以它不需要改变来处理最新版本(v1.7.5写这个的时候)。