安装API Connect工具包时的完整性校验和失败#apiconnect

安装API Connect工具包时出现以下错误:

sha1-UhOHSxsj + deaxi0QbjKXDirzcn8 =使用sha1时的完整性校验和失败:想要sha1-UhOHSxsj + deaxi0QbjKXDirzcn8 =但得到了sha1-208ds / bfbkHrcce1kMfz2sLUPhs =。 (627039字节)

节点版本: – 6.10.3 NPM版本: – 5.0.1

我试图使用npm install -g apiconnect命令在Windows 7工作站(64位)上安装API Connect工具包。

解决这个问题的下一步可能是什么?

       

网上收集的解决方案 "安装API Connect工具包时的完整性校验和失败#apiconnect"

在Node 10(v8.1.0)和Windows 10的NPM(5.0.3)版本中出现类似的错误。按照以下步骤解决此问题。 a)完全卸载npm&Node.js。 b)从“C:\ Users \\ AppData \ Roaming”位置删除“npm”和“npm-cache”文件夹。 c)通过节点命令提示符“.msi”d)安装最新的节点版本运行“npm i -g npm”e)移动到你的项目位置并运行“npm install”它应该工作。

我也遇到了同样的问题,但解决了

(第一个得到npm 4.xx的旧版本)

npm install -g npm@4.6.1

下一个可选的在你的情况下,如果你正在build设的东西,并在您的项目package.lock.json是存在的删除package.lock.json (这意味着节点版本5已安装hance一些安装程序(就像在Heroku应用程序部署应用程序)自动检测这个文件并升级到版本5)

现在尝试npm安装它应该工作

谢谢

再试一次,添加params'–unsafe-perm = npm install -g plugman --unsafe-perm=true

纱线安装

为类似的错误工作。 在这里检查