业绩问题,而试图build立一个有angular度的项目

我试图build立一个支持angular / coffeescript / sass / jade的环境,并且被告知angular度曲线做得非常出色。

我被困在这个部分:克隆repo和运行npm install我得到这个错误:

 npm ERR! peerinvalid The package karma does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer grunt-karma@0.5.4 wants karma@~0.9.4 || ~0.10 npm ERR! peerinvalid Peer karma-chrome-launcher@0.1.4 wants karma@>=0.9.3 npm ERR! peerinvalid Peer karma-firefox-launcher@0.1.3 wants karma@>=0.9 npm ERR! peerinvalid Peer karma-html2js-preprocessor@0.1.0 wants karma@>=0.9 npm ERR! peerinvalid Peer karma-jasmine@0.1.5 wants karma@>=0.9 npm ERR! peerinvalid Peer karma-requirejs@0.2.2 wants karma@>=0.9 npm ERR! peerinvalid Peer karma-script-launcher@0.1.0 wants karma@>=0.9 npm ERR! peerinvalid Peer karma-coffee-preprocessor@0.2.1 wants karma@>=0.11.14 npm ERR! peerinvalid Peer karma-phantomjs-launcher@0.1.4 wants karma@>=0.9 npm ERR! System Darwin 13.1.0 npm ERR! command "node" "/usr/local/bin/npm" "install" npm ERR! cwd /Users/abdullah/dev/js/sandbox/bayt npm ERR! node -v v0.10.26 npm ERR! npm -v 1.4.9 npm ERR! code EPEERINVALID npm ERR! npm ERR! Additional logging details can be found in: npm ERR! /Users/abdullah/dev/js/sandbox/bayt/npm-debug.log npm ERR! not ok code 0 

在这里看到我的npm ls的输出,而npm ls global返回空。

来自rails / bundler的背景,并阅读 npm允许嵌套的依赖(即你可以有2个库有不同版本的每个依赖项)我不明白为什么/如何发生这个问题。 帮助任何人?

       

网上收集的解决方案 "业绩问题,而试图build立一个有angular度的项目"

只要将package.json karma版本更改为"karma": "^0.9.0""karma": ">=0.9.0"并使npm update

更新

也尝试更新grunt-karma 。 我刚刚尝试过,以前的更改不起作用。 所以,正如你所提到的: "grunt-karma": ">=0.5.0""karma": ">=0.9.0",npm update

其实我通常从这样的过时的package文件中删除所有版本,并做npm update ,最终导致你必须更新它们(有点新手的事情也许,不build议)。 所以,如果以前没有帮助,你可以试试这个。 上次我只有一个最新版本的小问题。

在此之前,您还可以在控制台中inputnpm cache clean