安装Cordova时出现错误

当我想用npm来安装Cordova时,出现以下错误:

Error: No compatible version found: ripple-emulator@'>=0.9.15' 

Node,Nodejs和npm都安装完毕。 我找不到任何可能的帮助。
我的命令是:

 npm install cordova 

要么

 sudo npm install -g cordova 

       

网上收集的解决方案 "安装Cordova时出现错误"

你的Node.js版本可能太旧了。 ripple-emulator至less需要0.8.0,使用node -v检查你的版本。

如果是这种情况,您必须从您的发行版中获取更新的软件包,或者从nodejs.org下载并安装更新的版本。

这是对我来说(虽然我安装了apt-get,我有节点0.6,而更新的版本是0.10.31):添加节点到您的来源:

 sudo apt-add-rep ository ppa:chris-lea/node.js 

然后更新来源

 sudo apt-get update 

然后安装(或更新)nodejs

 sudo apt-get install nodejs 

来源: http : //doc.ubuntu-fr.org/nodejs (法文)