Cordova构build和gradle依赖关系

那么,这个项目就像一个魅力的工作。

更新整个堆栈的多个部分之后:

现在,运行: cordova build

返回以下错误:

 FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring root project 'android'. Could not resolve all dependencies for configuration ':_debugApk'. A problem occurred configuring project ':CordovaLib'. Could not resolve all dependencies for configuration ':CordovaLib:classpath'. Could not find com.android.tools.build:gradle:2.2.2. Searched in the following locations: https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.2/gradle-2.2.2.pom https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.2/gradle-2.2.2.jar Required by: android:CordovaLib:unspecified * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. 

当然,我尝试了“尝试”,但没有成功。

“有趣的”部分,Android工作室可以build立没有问题。 如果需要,我也可以粘贴gradle文件。

提前致谢

       

网上收集的解决方案 "Cordova构build和gradle依赖关系"

那么对不起,在StackOverflow中添加噪声,但是在阅读了TONS之后,我仍然无法解决这个问题。

所以我应用了西class牙的一句老话:为了制止愤怒,杀死那只狗。

所以我卸载了Android平台:

 cordova platforms remove android 

注意:有风险的移动,所以如果你这样做, 首先在平台上复制你的文件!

而且我已经重新安装了,可以通过以下方式解决:

 cordova platforms add android 

你知道吗? 有时祈祷有补偿!

一切开始像一个魅力工作-_-

我可以理解错误是什么,以及我发现的一些解决scheme,如下载依赖关系并在本地引用它。

但是,真诚的,我不认为这是一个很好的解决scheme。 主要是因为那么…存储库和依赖pipe理器有什么意义?

我认为这是不可接受的。 cordova堆栈中有一些真正的错误。

无论如何,到目前为止固定的经验教训,cordova项目是脆弱和难以维护。 真的很难。

免责声明 :我不信教,更重要的是,我完全反对任何forms的侵略/攻击等。 反对动物。 不要误解我比其他人更有趣的expression方式。

干杯!

通常这样的问题可能是由于Cordova框架或Android平台文件夹中的某些文件损坏所致。

删除和重新添加平台可以解决大部分时间的问题。 如果能够解决问题,重新安装Cordova而不是更新它可以解决问题。 希望能帮助到你。

我在windows上find了这个解决scheme:如果它没有find你的gradle或其他lib,

 c:\Users\YourUserName\.gradle\caches\ 

然后在命令提示符下转到您项目的目录并运行

 cordova build android 

cordova将为您下载它们并重新加载\caches目录和它的内容。

然后,你可能会被要求安装所需的Android SDK API(如果这样打开Andorid SDKpipe理器,并且安装Cordova所要求的API SDK级别),你将会获得成功的构build。