使用eslint-config-airbnb而无需反应插件

我想使用airbnbeslinter而不安装任何反应插件。 那可能吗?

基本上,我只想使用这个: eslint-config-airbnb 。 但它似乎是捆绑在一些反应特定的东西,因为它需要:

它需要eslint,eslint-plugin-import,eslint-plugin-react和eslint-plugin-jsx-a11y。

如果我不单独安装其他插件,我的Atom编辑器会抱怨:

错误:无法加载插件反应:找不到模块'eslint-plugin-react'引用自:airbnb引用自:/../../.eslintrc

那么如何在没有这些反应插件的情况下使用eslint-config-airbnb? (因为我不会使用反应)。

       

网上收集的解决方案 "使用eslint-config-airbnb而无需反应插件"