esprima-six npm模块发生了什么事?

我的npm项目有esprima-six npm模块作为传递依赖。 最近,已经不可能下载了,如下面的npm install输出所示:

 npm ERR! 404 Not Found npm ERR! 404 npm ERR! 404 'esprima-six' is not in the npm registry. npm ERR! 404 You should bug the author to publish it npm ERR! 404 It was specified as a dependency of 'syntax-error' npm ERR! 404 npm ERR! 404 Note that you can also install from a npm ERR! 404 tarball, folder, or http url, or git url. 

在npm网站上,找不到esprima-six: https ://www.npmjs.com/package/esprima-six

但Google的页面caching显示,它曾经存在: http : //webcache.googleusercontent.com/search?q= cache:81uuMFHrDeMJ:https: //www.npmjs.com/package/esprima-six+&cd=1&hl = EN&CT = clnk&GL = UK&客户= ubuntu的

那么为什么模块不可用? 什么是最好的方式让我的项目再次build设?

编辑:最后,我更新了依赖esprima-6的依赖到一个更高版本,不需要它。

       

网上收集的解决方案 "esprima-six npm模块发生了什么事?"

esprima-six已经没有发现 ,也没有了。

很难追查到底发生了什么,但似乎esprima-six是一个基于项目的非官方 harmony分支的模块,在2015年5月折扣之后 , esprima-fb (一个添加了JSX的分支句法)。

而现在esprima-six已经不再需要了,因为Esprima 2.0正式支持ES6 。

什么是最好的方式来让我的项目再次build设?

Esprima的维护者Ariya Hidayat的立场是,你应该转换到Esprima 2.x。

我的项目有esprima-six npm模块作为传递依赖。

在这种情况下,更新您的直接依赖关系可能就足够了,他们已经切换了。