当通过节点窗口运行应用程序时,excelparsing器不工作

我使用节点模块excelparsing器parsingexcel(xsl和xslx)。并且我使用node-window节点模块部署了应用程序。

我正在使用的节点模块:

https://github.com/vxtindia/excel-parser

它抛出的错误:

code: 1 killed: false signal: null 

它正在工作,如果我正常启动应用程序(节点server.js

我也为excel-parser安装了依赖关系:

https://github.com/vxtindia/excel-parser/wiki

 excelParser.parse({ inFile: path.join(exports.rootpath,'/public/data/bizsteps/users/',util.getCurrentUser(req),'/temp/','temperatureLog'+extension), worksheet: 1, skipEmpty: true },function(err, records){ if(err) { callback(err,null) }else{ _.each(records,function(element,index){records[index]=_.object(["time","temperature"], [parseFloat(element[0]),parseFloat(element[1])]); }); callback(null,records); } }); 

以上是我的code.Can任何人可以帮助我解决问题和解决scheme是什么?

       

网上收集的解决方案 "当通过节点窗口运行应用程序时,excelparsing器不工作"

尝试从shell显式运行python命令(显示在节点exception中),如下所示:

 python /home/michael/projects/some-project/node_modules/excel-parser/convert.py -x /tmp/test.xls 

看看它给你什么错误,你可以从那里拿走它。 在我的情况下,我不得不安装xlrd软件包。 如果是简单的情况:从这里下载xlrd zip:

https://pypi.python.org/packages/source/x/xlrd/xlrd-0.7.1.zip#md5=851bd20873224d97cfb5ccca2d22b81c

2)解压缩

3)cd到dir

4)sudo python setup.py安装