迁移到新控制台后,Firebase部署被破坏 – “错误:需要身份validation”。

将我的应用迁移到新的Firebase控制台(console.firebase.google.com)后,我无法再使用Firebase CLI“firebase deploy”部署静态资产。 我收到消息“错误:需要身份validation”。

起初,我已经更新到最新的CLI,但发现我无法使用它在我的Angular应用程序中更新Firebase的情况下进行部署; 我还没有准备好,直到AngularFire被更新。 所以我降级到旧的CLI,但发现我仍然无法部署。

我试着卸载/重新安装Firebase CLI,Firebase,NodeJS(v4&6),多次login和注销Firebase–没有任何帮助。

我目前正在使用:

  • Firebase CLI:2.15.1
  • 节点:4.4.4
  • NPM:2.15.1

我也尝试使用“firebase prefs:token”,复制令牌,并通过“firebase deploy –token”使用令牌进行部署。 仍然没有运气。 需要validation。

希望在这个问题上取消阻止部署的一些指导。 谢谢!

       

网上收集的解决方案 "迁移到新控制台后,Firebase部署被破坏 – “错误:需要身份validation”。"