无法使用Git部署到AWS Elastic Beanstalk

我正在关注Elastic Beanstalk文档( http://docs.aws.amazon.com/elasticbeanstalk/latest/dg/create_deploy_nodejs_express.html ),但是我无法部署node.js或PHP应用程序饭桶。

$ eb push Error: Failed to create the AWS Elastic Beanstalk application version Cannot run aws.push for local repository HEAD: 

如果我尝试从git中推送,也会发生同样的情况

 $ git aws.push Updating the AWS Elastic Beanstalk environment phpapp-env... Error: Failed to create the AWS Elastic Beanstalk application version 

当您调用eb init时,AWS工具会设置一些git快捷方式。 正在失败的电话是…

 $.git/AWSDevTools/aws.elasticbeanstalk.createapplicationversion Error: Failed to create the AWS Elastic Beanstalk application version 

该python模块的代码是…

 from aws.dev_tools import * if __name__ == "__main__": dev_tools = DevTools() dev_tools.create_application_version(None, None) 

我试过这个全新的php和node.js项目。 我正在运行Python 2.7.2,Ruby 2.1.2p95(2014-05-08修订版45877)[x86_64-darwin12.0]。 有什么想法吗?

       

网上收集的解决方案 "无法使用Git部署到AWS Elastic Beanstalk"

我们遇到了同样的错误信息,但不同的原因。 git commit的提交信息太长或包含特殊字符。 使用更简单的git commit消息清除它。 希望这可以帮助别人!

这个错误只会咬人使用多个AWS账户的人。 看起来,如果您的环境variables中声明了AWS_CREDENTIAL_FILE,那么AWS工具将select该工具,而不是拾取为Beanstalk项目创build的本地证书。 您可以通过发出以下命令来检查正在使用哪个configuration。

 git aws.config 

告诉我证书来自…

 /Users/a12345/.ec2/CLI_Access_User.iam 

…而不是当地的环境。 我希望错误消息表明这是一个权限问题。

当我用完应用程序版本时,这发生在我身上,有500的限制

我有另一个可能的原因,这个错误,debugging我得到这个:

 {"Error": {"Code":"TooManyApplicationVersionsException", "Message":"You cannot have more than 500 Application Versions. Either remove some Application Versions or request a limit increase.", "Type":"Sender"}, "RequestId":"xxxxxxxx-8184-11e4-xxxx-d5d8eef7a812"} 

当然,AWSDevTools应该抛出那些比Error: Failed to create the AWS Elastic Beanstalk application version信息更多的Error: Failed to create the AWS Elastic Beanstalk application version ,甚至Error: Failed to create the AWS Elastic Beanstalk application version提供--verbose选项。

解决方法是: Amazon Elastick BeanStalk错误:无法创buildAW​​S Elastic Beanstalk应用程序版本

Genrelly上传到亚马逊版本太多。

以上可以为某人工作,但如果你仍然发现问题,请检查你的git aws.config,因为如果你正在多个帐户的多个Beanstalk尝试检查,如果这是正确的。