软件包grunt不满足其兄弟的peerDependencies要求

我试图创build我的咕噜生成,但卡在以下错误

npm WARN package.json Dependency 'grunt' exists in both dependencies and devDependencies, using 'grunt@~0.4.2' from dependencies npm ERR! Darwin 13.4.0 npm ERR! argv "node" "/usr/local/bin/npm" "install" npm ERR! node v0.12.0 npm ERR! npm v2.5.1 npm ERR! code EPEERINVALID npm ERR! peerinvalid The package grunt does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer grunt-contrib-requirejs@0.4.4 wants grunt@~0.4.0 npm ERR! peerinvalid Peer grunt-config@0.1.8 wants grunt@~0.4.0 npm ERR! peerinvalid Peer grunt-string-replace@0.2.8 wants grunt@~0.4.1 npm ERR! peerinvalid Peer grunt-contrib-clean@0.5.0 wants grunt@~0.4.0 npm ERR! peerinvalid Peer grunt-contrib-cssmin@0.10.0 wants grunt@~0.4.1 npm ERR! peerinvalid Peer grunt-contrib-jshint@0.11.0 wants grunt@~0.4.5 npm ERR! peerinvalid Peer grunt-contrib-uglify@0.8.0 wants grunt@>=0.4.0 npm ERR! peerinvalid Peer grunt-exec@0.4.6 wants grunt@~0.4 

如上所述,我卸载了我的节点,npm和grunt,并重新安装了它们,但仍面临同样的问题?

任何想法 ?

我的JSON依赖是:

 "dependencies": { "grunt": "~0.4.2", "grunt-contrib-requirejs": "~0.4.1", "grunt-config": "~0.1.4", "grunt-string-replace": "~0.2.7", "grunt-contrib-clean": "~0.5.0", "grunt-contrib-cssmin": "~0.10.0" }, "devDependencies": { "grunt": "0.4.2", "grunt-cli": "0.1.13", "grunt-contrib-jshint": ">0.8.0", "grunt-contrib-uglify": ">0.3.2", "load-grunt-tasks": ">=0.3.0", "requirejs": ">=2.1.10", "grunt-exec": "~0.4.5" } 

同样的事情为我的同事工作正常。

       

网上收集的解决方案 "软件包grunt不满足其兄弟的peerDependencies要求"

我今天有类似的错误,并通过升级npm来修复它:

 npm install -g npm 

我有版本2.14和升级后成为3.8

你声明了两次grunt依赖。 一个发展,一个不是。 两者都有不同的版本规则。 这是导致冲突的原因。

你应该删除其中的一个。 (通常咕噜声是依赖的一部分)

依赖

 "grunt": "~0.4.2", 

devDependencies

 "grunt": "0.4.2", 

编辑:

我testing了它,解决了这个问题:

 "dependencies": { "grunt-contrib-requirejs": "~0.4.1", "grunt-config": "~0.1.4", "grunt-string-replace": "~0.2.7", "grunt-contrib-clean": "~0.5.0", "grunt-contrib-cssmin": "~0.10.0" }, "devDependencies": { "grunt": "~0.4.2", "grunt-cli": "0.1.13", "grunt-contrib-jshint": ">0.8.0", "grunt-contrib-uglify": ">0.3.2", "load-grunt-tasks": ">=0.3.0", "requirejs": ">=2.1.10", "grunt-exec": "~0.4.5" } 

更新我所有的全球npm软件包解决了我的问题:

 npm update -g