Gulp:节点4.0更新后的分段错误11

我刚刚更新到节点4。

当我运行Gulp时,我看到:

分割故障:11

我包括:

var gulp = require('gulp'); var jscs = require('gulp-jscs'); var concat = require('gulp-concat'); var uglify = require('gulp-uglify'); var rename = require('gulp-rename'); var responsive = require('gulp-responsive'); var imagemin = require('gulp-imagemin'); var jpegtran = require('imagemin-jpegtran'); var rollup = require('gulp-rollup'); var webp = require('gulp-webp'); var spritesmith = require('gulp.spritesmith'); 

我无法获得debugging任务运行。 详细不会吐出任何额外的东西。

思考?

       

网上收集的解决方案 "Gulp:节点4.0更新后的分段错误11"

我也更新到节点4.0,并得到我的节点服务器上的分段错误。 我只是删除我的node_modules目录并重新运行npm install ,并没有问题。

所以我怀疑这是因为npm的新版本加载了一些旧的npm安装的模块有问题—但是对于某些模块来说,在我的其他服务器上更新后直接运行npm start就行了。 我没有深入这个。

作为一个快速解决scheme,我认为你可以尝试在你自己的依赖。

build议删除node_modules ,然后运行npm install是一个好主意。 它会工作。 但是,稍微高效一些,可能只是运行npm rebuild而不删除node_modules或运行npm install 。 它将重新编译已安装的新版本的Node / V8的本机模块,而无需再次下载所有文件。

但是,如果一切都失败了:

  • 删除你的node_modules目录
  • npm cache clean && npm install
  • npm uninstall -g gulp && npm install -g gulp

我最近遇到了这个问题,并尝试了上面显示的步骤:

 $ npm cache clean && npm install 

但仍然是错误。 即使在删除所有文件并运行之后

 $ npm install 

所以,做了更多的root,发现有一个问题,一些节点模块有一个以.info结尾的文件,导致Drupal(我正在运行这个框架)尝试读取.info文件。 theme.info文件。 重命名这些文件(用不同的结尾)解决了这个问题。

虽然我的问题Drupal的具体,我可以想象类似的问题出现在其他框架,以及。

我遇到的问题是我安装了Node v5.9.0。 于是我降级到了v4.4.1-LTS,最后又重新开始工作:

使用自制软件:

 $ brew tap homebrew/versions $ brew install homebrew/versions/node4-lts 

接着:

 $ npm rebuild 

我今天再次遇到这个bug。 经过大约一个小时的search,重新安装整个node.js,所有的插件,吞咽和清理NPM的caching,而不解决。 我试图回到我的SASS文件中的几个草原。

并修复它。 但是这不是代码中的一些错误或variables,而是我把这个声明写到我的文件中:

 a transition: all 0.5s ease-in-out &:hover, &:focus transition: all 0.5s ease-in-out 

试图让它一次又一次的错误发生。 真的不知道为什么。 当我使用嵌套在类或其他标签中的这个语句时,它正常工作。

请从项目中删除您的node_modules并执行npm install