'gyp'在退出代码:1时试图使用npm在窗口上安装zookeeper

我尝试使用npm 1.3.9在Windows 7上安装Zookeeper 3.4.5。 当我进入

npm安装zookeeper

我明白了

File "C:\Program Files\npm-1.3.9\node_modules\npm\node_modules\node-gyp\gyp\pylib\gyp\MSVSProject.py", line 181, in AddFileConfig raise ValueError('AddFileConfig: file "%s" not in project.' % path) ValueError: AddFileConfig: file "." not in project. gyp ERR! configure error gyp ERR! stack Error: `gyp` failed with exit code: 1 gyp ERR! stack at ChildProcess.onCpExit (C:\Program Files\npm-1.3.9\node_modules\npm\node_modules\node-gyp\lib\configure.js:424:16) gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:98:17) gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:789:12) gyp ERR! System Windows_NT 6.1.7601 gyp ERR! command "node" "C:\\Program Files\\npm-1.3.9\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" gyp ERR! cwd C:\Program Files\Zookeeper-3.4.5\node_modules\zookeeper gyp ERR! node -v v0.10.17 gyp ERR! node-gyp -v v0.10.9 gyp ERR! not ok npm ERR! weird error 1 npm ERR! not ok code 0 

       

网上收集的解决方案 "'gyp'在退出代码:1时试图使用npm在窗口上安装zookeeper"

由于这是一个巨大而烦人的问题,我已经用许多不同的(非永久性的)方式解决了,我最终在这里find了答案:

在Ubuntu上安装node-gyp时出错

既然你是在Windows上,那么试着使用以前版本的Python(对我来说,它使用的是2.6)。

试试这个node-gyp安装 。 这对我很有用。

够了:

 npm install --global --production windows-build-tools