要求highcharts-browserify使用特定版本的highcharts?

我正在使用highcharts-browserify 。 这就是我的package.json文件的样子:

{ "main": "index.js", "scripts": { "watch-index": "watchify index.js -o ../../static/js/index.js --debug --verbose", "watch": "npm run watch-index", "build-index": "browserify index.js | uglifyjs > ../../static/js/index.min.js", "build": "npm run build-index" }, "dependencies": { "highcharts-browserify": "^0.1.5-4.1.7", "jquery": "^1.11.3", } } 

但是,当我运行npm run watch ,编译的文件中有Highcharts的v4.0.4,而不是最新的版本(v4.1.7)。

我怎样才能确保我有最新版本?

我需要使用最新版本,因为Highcharts v4.0.4中的x轴标签中存在这个错误: http : //jsfiddle.net/5z8rf83y/7/

       

网上收集的解决方案 "要求highcharts-browserify使用特定版本的highcharts?"

highcharts-browserify库目前使用v 4.0.4。

https://github.com/soldair/highcharts-browserify/blob/master/highcharts.js#L2

你可以打开一张票来更新它,或者修改它并提交一个拉取请求。

另外,你可以通过使用这个库,并使用browserify-shim看起来像这样 –

 { "browserify": { "transform": [ "browserify-shim" ] }, "browserify-shim": { "Highcharts": { "depends": ["HighchartsAdapter:HighchartsAdapter"], "exports": "Highcharts" }, "HighchartsAdapter": {"exports":"HighchartsAdapter"} }, "browser": { "Highcharts": "./bower_components/highcharts-release/highcharts.src.js", "HighchartsAdapter": "./bower_components/highcharts-release/adapters/standalone-framework.src.js" } }