将自定义节点JS版本添加到openshift不适用于我的应用程序

我写了一个需要Node.js> = 4.2.6的应用程序我使用OpenShift服务,默认的Node.Js版本是0.10。 安装这个https://github.com/ryanj/nodejs-custom-version-openshift应该可以解决这个问题。 所以我按照说明创build了一个新的应用程序,使用:

rhc app create nodeapp nodejs –from-code = git://github.com/ryanj/nodejs-custom-version-openshift.git

到现在为止还挺好。 下一步 – 将我的项目复制到克隆的git存储库。 这里是我不确定我的方法是否正确(新的Node js)。 由于克隆的git已经有一个JSON包,而且因为我的应用程序在其根目录中有自己的JSON包,所以我使用我的依赖关系丰富了与nodejs-custom-version-openshift.git一起提供的JSON包,并将引擎设置为4.2。 6。 主要设置为server.js。 要运行我的应用程序,我使用“var variable = require('./ myapp-master / test / test');” 作为我的server.js中的最后一行。 我复制我的应用程序的内容到克隆的存储库(包括节点模块等),小心不要覆盖任何现有的configuration文件,如JSON包,然后我使用git push。 节点版本根据日志(在构build时)正确安装,servers.js被执行并调用我的test.js. 我可以在应用程序日志(app-root / logs)中看到test.js抛出一个指定节点js版本不是> = 4.2.6的特定错误。

当我用PUTTYlogin和写节点-v,我得到4.2.6。 当我导航到我的test.js并用节点test.js手动启动它时,它运行正常。 我究竟做错了什么? 我怀疑我没有正确处理JSON包(或者我的方法从server.js启动我的应用程序是有缺陷的)。 任何帮助是极大的赞赏! 感谢您的时间。

       

网上收集的解决方案 "将自定义节点JS版本添加到openshift不适用于我的应用程序"