缺less脚本:在Windows_NT 6.2.9200上的吞咽错误

我需要用这个命令在windows 8中运行gulp

npm run gulp 

但在尝试运行该命令后,我在cmd和npm-debug.log中看到以下错误:

 0 info it worked if it ends with ok 1 verbose cli [ 'C:\\Program Files\\nodejs\\node.exe', 1 verbose cli 'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js', 1 verbose cli 'run', 1 verbose cli 'gulp' ] 2 info using npm@2.14.12 3 info using node@v4.3.2 4 verbose stack Error: missing script: gulp 4 verbose stack at run (C:\Program Files\nodejs\node_modules\npm\lib\run-script.js:142:19) 4 verbose stack at C:\Program Files\nodejs\node_modules\npm\lib\run-script.js:58:5 4 verbose stack at C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:345:5 4 verbose stack at checkBinReferences_ (C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:309:45) 4 verbose stack at final (C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:343:3) 4 verbose stack at then (C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:113:5) 4 verbose stack at C:\Program Files\nodejs\node_modules\npm\node_modules\read-package-json\read-json.js:232:12 4 verbose stack at C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\graceful-fs.js:76:16 4 verbose stack at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:380:3) 5 verbose cwd C:\Users\UserN\Desktop\App 6 error Windows_NT 6.2.9200 7 error argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "run" "gulp" 8 error node v4.3.2 9 error npm v2.14.12 10 error missing script: gulp 11 error If you need help, you may report this error at: 11 error <https://github.com/npm/npm/issues> 12 verbose exit [ 1, true ] 

编辑:

gulpfile:

 var gulp = require('gulp'); var requireDir = require('require-dir'); requireDir('./gulp-tasks'); gulp.task('default', ['sass', 'templatecache']); 

如何解决这个问题,并在我的环境中运行没有错误?

       

网上收集的解决方案 "缺less脚本:在Windows_NT 6.2.9200上的吞咽错误"

你没有在你的package.json定义的gulp脚本。 任何以npm run为前缀的命令行命令npm run应该在package.jsonscripts部分定义。 从文档 :

这从包的“脚本”对象运行一个任意命令。

您可以定义一个大gulp脚本,也可以从命令行运行大gulp

 gulp 

从入门指南 :

1.全球安装gulp:

 $ npm install --global gulp 

2.在您的项目devDependencies中安装gulp:

 $ npm install --save-dev gulp 

3.在项目的根目录下创build一个gulpfile.js文件:

 var gulp = require('gulp'); gulp.task('default', function() { // place code for your default task here }); 

4.运行gulp:

 $ gulp