Mac OS Mavericks上的NPM安装问题

我正在努力去处理AngularJS,NodeJS和Ruby on Rails。 当试图安装像yeoman,grunt等npm包时,我收到我在下面列出的terminal中的错误:

  npm ERR! 错误:EACCES,打开“/Users/Jabane/.npm/glob/3.2.11/package/package.json.25961” 
npm ERR! {[错误:EACCES,打开'/Users/Jabane/.npm/glob/3.2.11/package/package.json.25961']
npm ERR! errno:3,
npm ERR! 代码:'EACCES',
npm ERR! path:'/Users/Jabane/.npm/glob/3.2.11/package/package.json.25961',
npm ERR! 父:“browserify”}
npm ERR!
npm ERR! 请尝试以root / Administrator身份再次运行此命令。
npm ERR! 系统达尔文13.0.0
npm ERR! 命令“node”“/ usr / local / bin / npm”“install”“-g”“browserify”
npm ERR! cwd / Users / Jabane
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.16
npm ERR! path /Users/Jabane/.npm/glob/3.2.11/package/package.json.25961
npm ERR! 代码EACCES
npm ERR! errno 3
npm ERR! 堆栈错误:EACCES,打开'/Users/Jabane/.npm/glob/3.2.11/package/package.json.25961'
npm ERR!
npm ERR! 其他日志logging详细信息可以在
npm ERR! /Users/kJabane/npm-debug.log
npm ERR! 不好的代码0

在这种情况下可能是什么问题? 非常感谢您的帮助。

谢谢

       

网上收集的解决方案 "Mac OS Mavericks上的NPM安装问题"