是否有可能在meteor应用程序中使用本地(未发布)节点模块?

在Node中,您可以使用以下方式要求本地模块:

var myModule = require('./lib/mymodule.js'); 

是否有可能做类似的meteor

       

网上收集的解决方案 "是否有可能在meteor应用程序中使用本地(未发布)节点模块?"

下面是一个简单的例子,让你开始:

让我们在npm下安装下划线作为我们的应用服务器目录中的本地节点模块:

 cd server npm install underscore 

然后在server/startup.js键入以下代码:

 var underscoreLatest=Npm.require(process.cwd()+"/app/server/node_modules/underscore/underscore.js"); Meteor.startup(function(){ // will display "1.7.0" as of december 2014 console.log(underscoreLatest.VERSION); }); 

所以基本上你需要使用Npm.require而不是require ,你必须小心,Meteor Node.JS进程当前工作目录不是Meteor项目目录的根目录,而是".meteor/local/build/programs/server"