meteorHeroku应用程序部署后崩溃

将应用程序部署到heroku后,我的应用程序无法启动。 我认为这可能是与构build包和最新版本的meteor0.9.x?

我应该从哪里开始debugging?

2014-09-02T05:02:58.848513+00:00 heroku[web.1]: State changed from crashed to starting 2014-09-02T05:03:05.407436+00:00 heroku[web.1]: Starting process with command `.meteor/heroku_build/bin/node .meteor/heroku_build/app/main.js` 2014-09-02T05:03:06.578829+00:00 app[web.1]: module.js:340 2014-09-02T05:03:06.579092+00:00 app[web.1]: throw err; 2014-09-02T05:03:06.586422+00:00 app[web.1]: at Function.Module._load (module.js:280:25) 2014-09-02T05:03:06.578419+00:00 app[web.1]: 2014-09-02T05:03:06.586423+00:00 app[web.1]: at Module.require (module.js:364:17) 2014-09-02T05:03:06.579105+00:00 app[web.1]: ^ 2014-09-02T05:03:06.586414+00:00 app[web.1]: Error: Cannot find module 'fibers' 2014-09-02T05:03:06.586426+00:00 app[web.1]: at require (module.js:380:17) 2014-09-02T05:03:06.586420+00:00 app[web.1]: at Function.Module._resolveFilename (module.js:338:15) 2014-09-02T05:03:06.586428+00:00 app[web.1]: at Object.<anonymous> (/app/.meteor/heroku_build/app/programs/server/boot.js:1:75) 2014-09-02T05:03:06.586429+00:00 app[web.1]: at Module._compile (module.js:456:26) 2014-09-02T05:03:06.586431+00:00 app[web.1]: at Object.Module._extensions..js (module.js:474:10) 2014-09-02T05:03:06.586432+00:00 app[web.1]: at Module.load (module.js:356:32) 2014-09-02T05:03:06.586434+00:00 app[web.1]: at Function.Module._load (module.js:312:12) 2014-09-02T05:03:06.586436+00:00 app[web.1]: at Module.require (module.js:364:17) 2014-09-02T05:03:07.681468+00:00 heroku[web.1]: State changed from starting to crashed 2014-09-02T05:03:07.680466+00:00 heroku[web.1]: Process exited with status 8 

       

网上收集的解决方案 "meteorHeroku应用程序部署后崩溃"

我没有足够的积分来留言,但是这样可以解决你的问题,即使它不能回答你的问题。 这个问题一个多月没有回答,为什么不呢?

你是对的。 很多stream行的buildpack都遇到了meteor0.9.x的问题; 我不是一个足够好的程序员来理解为什么或者是什么问题。 我也不知道为什么下面链接的构build包工作,但它确实。

https://github.com/djhi/heroku-buildpack-meteorite.git

希望这将有助于其他meteor开发者遭受同样的问题,即使这个职位不回答这个问题。

编辑 – 更新文章per @ jww的评论; 我的post仍然没有提供答案,但它确实提供了一个解决scheme。

编辑2 – 这个buildpack不再为我工作。 看到我下面的评论。 以下是我的工作: https : //github.com/AdmitHub/meteor-buildpack-horse

我有这个问题。 这是因为节点版本,meteor支持节点0.10.36或更高的版本

我只是按照我的步骤,它的工作很好

创buildmeteor应用程序,并确保它运行没有任何错误。

 meteor create todo 

转到待办事项应用程序目录

 cd todo 

添加并提交GIT

 git init git add . git commit -am "Initial commit" 

使用buildpack创buildheroku应用程序

 heroku create --buildpack https://github.com/kannans/heroku-buildpack-meteor.git 

添加meteorherokuconfiguration

 heroku addons:add mongolab:sandbox heroku config:add MONGO_URL=<mangolap url> heroku config:add ROOT_URL=https://damp-bastion-7974.herokuapp.com/ 

对于MONGO_URL。 只需从https://mongolab.com/创build帐户并获取url

将您的更改推送到Heroku。

 git push heroku master 

我在Heroku的meteor应用程序:) https://damp-bastion-7974.herokuapp.com/