是否仍然有必要提供MongoDB驱动程序?

这个问题的答案仍然是相关的: 我怎样才能使用蓝鸟promisify MongoDB原生的Javascript驱动程序?

我不知道从什么时候这是更新,但2.0的MongoDB的JS驱动程序在选项对象promiseLibrary有一个属性: http : promiseLibrary

大多数方法/函数都会返回一个promise,比如Cursor.toArray()

但是,我找不到使用这个新选项的例子,但是使用这个方法并不简单:

 MongoClient.connect('mongodb://URL', { promiseLibrary: require('bluebird') }); 

或者这个定义是错误的? – 在这种情况下,应该如何正确定义?

更新:

代码在io.js上运行,所以我可能甚至不需要指定一个promiseLibrary作为驱动程序将使用ES6承诺? 然而,据说蓝鸟的承诺是较慢的:

为什么本机ES6承诺比bluebird更慢,更占用内存?

Update2:我已经添加了蓝鸟标签 – 也许蓝鸟工作的人可以提供更多的细节,如果promisifying真的比使用MongoDB自己的实现更好?

       

网上收集的解决方案 "是否仍然有必要提供MongoDB驱动程序?"

是否仍然有必要提供MongoDB驱动程序?

不,他们现在已经build立了对蓝鸟这样的承诺库的支持。 我认为我们应该以不同的方式提出这个问题:

MongoDB驱动程序是否是个好主意?

或许,蓝鸟在将callbackAPI转换为承诺方面做得比Mongo驱动程序在内部做得更好,因为它可以轻松地包装得更多。 还有可能会比以前“更快”。