找不到兼容版本:mongodb@3.2.8

npm的错误消息说,最新版本的mongodb是2.2.6?

我试过“npm install -g npm”:现在是npm@3.10.6

更新所有其他的东西。

还是行不通。

我的本地mongodb版本是3.2.8,最新的一个。 我是NodeJS的新手。 当我尝试编写“package.json”文件时,是否必须写入与“”mongodb“:”3.2.8“”相同的版本?

我之所以想要安装3.2.8版本,是因为我得到了“拒绝连接问题”,看到有人在网上说我们应该有和已经安装的mongodb版本相同的版本。

总之,我可能需要“npm安装”mongodb 3.2.8,但我不能因为没有find。

       

网上收集的解决方案 "找不到兼容版本:mongodb@3.2.8"

MongoDB数据库和nodejs mongodb驱动程序之间有区别。 这可能会令人困惑,因为它们都被称为mongodb ,但npm install与MongoDB数据库本身无关。 您正在安装允许您的应用程序使用MongoDB的nodejs驱动程序。

该驱动程序的最新版本是2.2.6 。 如果你正在开始一个新的项目,我会从你的package.json删除mongodb ,只是做npm install --save mongodb ,它应该添加^2.2.6作为mongodb版本,如果它是尚未安装。

你的npm版本与此无关,特别是如果你使用的是最新的主要版本npm 3