mongodb是否只运行MongoDB版本1.4以上?

我想了解nodejs,expressmongodb我正在运行mongodb v 2.0.6和最新的nodejs和expression并试图通过mongoskin连接快速应用程序与mongodb。 问题是:

npm ERR! peerinvalid The package mongodb does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer mongoskin@1.4.13 wants mongodb@~1.4 

这是否意味着mongoskin只能使用mongodb v 1.4? 这个版本对我来说是旧的(现在是3)

       

网上收集的解决方案 "mongodb是否只运行MongoDB版本1.4以上?"

它期望MongoDB 驱动程序的版本1.4,而不是数据库。

你应该删除驱动程序的2.0.6版本,因为mongoskin还没有工作( 问题 ),而是安装1.4版本:

 $ npm uninstall mongodb $ npm install mongodb@~1.4 [--save] $ npm install mongoskin [--save] 

(但是,我不确定1.4驱动程序是否可以正确使用3.x数据库)