mongoose – 不赞成mongodb@2.2.16:请升级到2.2.19或更高?

当我尝试安装mongoose时,为什么我会在下面看到这个警告信息?

npm WARN弃用mongodb@2.2.16:请升级到2.2.19或更高版本

JSON:

{ "name": "dummy-app", "version": "0.0.0", "private": true, "scripts": { "start": "node ./bin/www" }, "dependencies": { "body-parser": "~1.15.1", "cookie-parser": "~1.4.3", "debug": "~2.2.0", "express": "~4.13.4", "pug": "~2.0.0-beta3", "morgan": "~1.7.0", "serve-favicon": "~2.3.0", "mongoose": "^4.7.6" } } 

我该如何解决这个问题?

       

网上收集的解决方案 "mongoose – 不赞成mongodb@2.2.16:请升级到2.2.19或更高?"

npm软件包mongodbmongodb的一个依赖项:当你安装mongoose时它会自动安装npm。

mongoose v4.7.6取决于mongodb 2.2.16(请参阅它的package.json文件 ),但是有一个更新的bugfix发行版(2.2.19),这就是为什么你会看到这个警告。

由于mongodb是mongoose的依赖关系,因此您必须等待mongoose维护者更新依赖关系:这不是您必须在代码中修复的问题。

事实上,这个问题已经在mongoose的Github 这里跟踪了。