mongoskin和mongoose依赖性错误

我是新来的全堆栈的JavaScript,一直卡在这个错误一段时间了。 起初,我在运行“npm-install”时看到了这个:

npm WARN EPEERINVALID mongoskin@1.4.13需要mongodb@~1.4的同行,但没有安装。

当我做nodemon server.js,我得到以下错误:

/Users…/node_modules/agenda/node_modules/mongoskin/lib/utils.js:33 var skinClassName ='Skin'+ NativeClass.name; ^

TypeError:无法在makeSkinClass(/ Users / ….)中读取未定义的属性'name'

我看到这似乎也是其他人的问题: https : //github.com/kissjs/node-mongoskin/issues/153

但我真的不知道如何进行。 哪个package.json文件(和哪里)我应该编辑,并为什么原因? 我的npm_modules文件夹中没有“修士”。

       

网上收集的解决方案 "mongoskin和mongoose依赖性错误"

这个修好了! 你必须在项目目录下安装mongodb并指定版本。

https://github.com/Automattic/monk/issues/91

将这行添加到package.json中,然后在你的项目目录中再次运行'npm install'。它会重新安装/降级mongodb到版本1.4.4,'mongoskin'将完全安装…

"mongodb": "^1.4.4", 

我通过安装旧版本的MongoDb解决了这个问题。 按着这些次序:

  1. npm uninsatll mongodb – 保存

  2. npm安装mongodb@1.4 – 保存

  3. npm安装修士 – 保存

希望这个作品!