我如何在我的脚本中需要最低版本的node.js?

我刚发现我写的脚本只能在节点0.10上工作,因为它使用readable事件。

如何在我的脚本中需要最低版本的node.js,以便用户知道他们需要升级?

       

网上收集的解决方案 "我如何在我的脚本中需要最低版本的node.js?"

在package.json中:

 { "engines" : { "node" : ">=0.10.3" } } 

从文档 。

编辑,一个编程方式:

 var pkg = require('./pacakge'), semver = require('semver'); if(!semver.satisfies(process.version, pkg.engines.node)) { // Not sure if throw or process.exit is best. throw new Error('Requires a node version matching ' + pkg.engines.node); } 

将此添加到脚本的顶部。

 var versionComps = process.versions['node'].split('.'); if (parseInt(versionComps[0]) === 0 && parseInt(versionComps[1]) < 10) { console.log('Script requires node.js version >= 0.10'); process.exit(1); };