对Node.js的Ecmascript 6支持

我一直在使用KoaJS一段时间,当使用–harmony标志时,我们可以很容易地使用'let'关键字和生成器,但是我找不到节点v0.11.x提供了多less支持同时使用相同的。

我尝试使用默认值参数初始化,但不能成功。

是否有任何可用的源代码可以列出节点v0.11.x中使用和声标志支持的ECS 6的function? 或者如果有任何npm模块可用于节点,可能允许我使用相同的?

提前致谢。

       

网上收集的解决方案 "对Node.js的Ecmascript 6支持"

关于你的第二个问题,是的,有es6-module-loader 。 有关使用完整ES6function的转换器,垫片和其他工具的详细列表,请参阅addyosmani的ECMAScript 6工具页面 。

至于node.js中的本地ES6支持,V8正式实现了“ECMAScript”,但是AFAIK V8项目并没有公布它们实现的规范。 不过,这里有一些有用的信息来源。 以下是node.js v0.11.6中ES6的简要概述 。

您可能需要确定您的node.js版本使用的V8版本 。 查看node.js博客获取最近的更新日志信息。 find给定的Chromium版本中使用的V8版本也是有用的。 Chrome发行说明可以在这里find。 请记住,可以为相同版本的V8设置不同的标志。 Chromium和node.js都可以在V8中设置与ES6支持相关的标志 。

以下是两个表,其中列出了跨实现的ES(6)function支持:

此MDN页面列出了ES6语言function的一组参考文章。 在每个底部可以看到Chrome对该function的支持状态(使用V8版本确定node.js中的支持)。

最后, V8问题跟踪器提供了与ES6function相关的问题列表,其中许多问题已经实施并且问题已经closures。

您可以使用Node.js 6中大约96%的ES6function。您可以在http://node.green/上查看对所有版本的支持。

这与节点0.11无关,但在当前的5.8.0中,可以使用--harmony_default_parameter

它计划默认包含在v6.0中。