我应该安装哪个Node.js模块才能使用google协议缓冲区?

似乎有多个模块可用于多个人的Node.js使用协议缓冲区。 有些或多或less积极维护。 我发现https://github.com/chrisdew/protobuf这似乎工作正常。 但是,有没有一个真正的(正式authentication的)path?

       

网上收集的解决方案 "我应该安装哪个Node.js模块才能使用google协议缓冲区?"

除了Java,Python和C ++之外,没有Protobuf的官方实现。 对于node.js,你可能会想用chrisdew,因为它是npm上的。 我个人使用我自己的叉子,因为我需要与int64的工作。

毫无疑问…更好,完整和精美的devise是: Protobuf.js

干杯!

值得一提的是protocol-buffers nodejs软件包

现在你已经有一个JS谷歌正式版本。 你可以在这里下载https://github.com/google/protobuf/releases