在node.js中安装Socket.io包

1)安装的节点v0.10.13 X64 (我在Win 8中)

2)用pipe理员权限打开CMD

3)键入npm install socket.io它下载的东西,但它显示最后一个像一个build立错误的东西

 npm http GET https://registry.npmjs.org/socket.io npm http 304 https://registry.npmjs.org/socket.io unbuild socket.io@0.9.16 npm http GET https://registry.npmjs.org/socket.io-client/0.9.16 npm http GET https://registry.npmjs.org/policyfile/0.0.4 npm http GET https://registry.npmjs.org/base64id/0.1.0 npm http GET https://registry.npmjs.org/redis/0.7.3 npm http 304 https://registry.npmjs.org/base64id/0.1.0 npm http 304 https://registry.npmjs.org/socket.io-client/0.9.16 npm http 304 https://registry.npmjs.org/policyfile/0.0.4 npm http GET https://registry.npmjs.org/base64id/-/base64id-0.1.0.tgz npm http GET https://registry.npmjs.org/socket.io-client/-/socket.io-client-0.9. 16.tgz npm http GET https://registry.npmjs.org/policyfile/-/policyfile-0.0.4.tgz npm http 304 https://registry.npmjs.org/redis/0.7.3 npm http 200 https://registry.npmjs.org/socket.io-client/-/socket.io-client-0.9. 16.tgz npm http 200 https://registry.npmjs.org/base64id/-/base64id-0.1.0.tgz npm http 200 https://registry.npmjs.org/policyfile/-/policyfile-0.0.4.tgz npm http GET https://registry.npmjs.org/uglify-js/1.2.5 npm http GET https://registry.npmjs.org/xmlhttprequest/1.4.2 npm http GET https://registry.npmjs.org/ws npm http GET https://registry.npmjs.org/active-x-obfuscator/0.0.1 npm http 304 https://registry.npmjs.org/xmlhttprequest/1.4.2 npm http 304 https://registry.npmjs.org/uglify-js/1.2.5 npm http 304 https://registry.npmjs.org/ws npm http GET https://registry.npmjs.org/xmlhttprequest/-/xmlhttprequest-1.4.2.tg z npm http 304 https://registry.npmjs.org/active-x-obfuscator/0.0.1 npm http GET https://registry.npmjs.org/uglify-js/-/uglify-js-1.2.5.tgz npm http GET https://registry.npmjs.org/active-x-obfuscator/-/active-x-obfuscato r-0.0.1.tgz npm http 200 https://registry.npmjs.org/xmlhttprequest/-/xmlhttprequest-1.4.2.tg z npm http 200 https://registry.npmjs.org/uglify-js/-/uglify-js-1.2.5.tgz npm http 200 https://registry.npmjs.org/active-x-obfuscator/-/active-x-obfuscato r-0.0.1.tgz npm http GET https://registry.npmjs.org/zeparser/0.0.5 npm http GET https://registry.npmjs.org/tinycolor npm http GET https://registry.npmjs.org/commander npm http GET https://registry.npmjs.org/options npm http 304 https://registry.npmjs.org/zeparser/0.0.5 npm http 304 https://registry.npmjs.org/options npm http 304 https://registry.npmjs.org/commander npm http 304 https://registry.npmjs.org/tinycolor >ws@0.4.27 install C:\Windows\system32\node_modules\socket.io\node_modules\sock et.io-client\node_modules\ws > (node-gyp rebuild 2> builderror.log) || (exit 0) C:\Windows\system32\node_modules\socket.io\node_modules\socket.io-client\node_mo dules\ws>node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\ node_modules\node-gyp\bin\node-gyp.js" rebuild MSBUILD : error MSB1009: Project file does not exist. Switch: build/binding.sln socket.io@0.9.16 node_modules\socket.io ├── base64id@0.1.0 ├── policyfile@0.0.4 ├── redis@0.7.3 └── socket.io-client@0.9.16 (xmlhttprequest@1.4.2, uglify-js@1.2.5, active-x-obf uscator@0.0.1, ws@0.4.27) 

我也尝试了下面的一些博客的命令,但不知道这是什么意思,它不工作。

1)npm install express

2)npm安装玉器

3)npm install -g node -gyp

我想从早上安装找不到解决办法。请帮我解决。

       

网上收集的解决方案 "在node.js中安装Socket.io包"