Node.js找不到模块的“可读stream”

我是node.js的新手,并坚持以下几点。 任何帮助将不胜感激:

我在Ubuntu(12.10)上运行node.js(0.10.28)。 我正在处理的代码是:

"use strict"; var mysql = require('node-mysql'), connection = mysql.createConnection({ host: "127.0.0.1", user: "user", password: "password", database: "dbname" }); if(connection) { console.log("Query"); connection.query("select * from client",function(err,res) { if(err)console.log(err); console.log(res); }); } 

我得到以下错误

 Error: Cannot find module 'readable-stream' at Function.Module._resolveFilename (module.js:338:15) at Function.Module._load (module.js:280:25) at Module.require (module.js:364:17) at require (module.js:380:17) at Object.<anonymous> (/root/RonakNodeEmail/node_modules/node-mysql/lib/protocol/sequences/Query.js:7:20) at Module._compile (module.js:456:26) at Object.Module._extensions..js (module.js:474:10) at Module.load (module.js:356:32) at Function.Module._load (module.js:312:12) at Module.require (module.js:364:17) 

       

网上收集的解决方案 "Node.js找不到模块的“可读stream”"

我得到了这个错误很长一段时间。 愚蠢我没有安装吞…总之,这个问题发生在一个包缺失。

 npm install gulp -g 

我会build议你正在运行哪个任务,然后安装它。

这个问题有很多原因:我遇到了这个问题,因为我有更旧版本的node.js相关文件。

  1. 取消安装node.js
  2. 转到您的用户文件夹,如C:\Users\<uname> ,find所有与node.js相关的文件并删除所有内容。
  3. 新鲜安装node.js

它为我工作。

之后我发现:

  $ cd /usr/lib/ $ ack-grep readable-stream nodejs/sha/index.js 3:var Transform = require('stream').Transform || require('readable-stream').Transform 

并将该行更改为:

 var Transform = require('stream').Transform // || require('readable-stream').Transform 

和错误出去!

– 系统信息: