在更新到Node v4.0.0后运行gulp-sass时出错

我更新到节点v4.0.0和之后,当我在我的项目中运行gulp时,我得到一个关于gulp-sass / node-sass错误,如下所示:

错误:未findlibsass绑定。 尝试重新安装node-sass

我已经尝试了垃圾邮件中的所有节点模块,并重新安装,我得到一些错误:

npm WARN package.json package@0.0.0没有版本库字段。

npm WARN package.json package@0.0.0无许可证字段。

npm WARN弃用CSSselect@0.4.1:模块现在可以用'css-select'

npm WARN弃用CSSwhat@0.4.7:模块现在可以用'css-what'

npm WARN弃用pangyp@2.3.2:使用node-gyp @ 3 +,它做所有事情

node-sass@2.1.1 install / Users / Jonathan / Documents / sites / wkux / ct-html-lib / node_modules / gulp-sass / node_modules / node-sass

节点脚本/ install.js

无法从https://raw.githubusercontent.com/sass/node-sass-binaries/v2.1.1/darwin-x64-node-4.0/binding.node下载文件

node-sass@2.1.1 postinstall / Users / Jonathan / Documents / sites / wkux / ct-html-lib / node_modules / gulp-sass / node_modules / node-sass

节点脚本/ build.js

gyp:/Users/Jonathan/.node-gyp/4.0.0/common.gypi not found(cwd:/ Users / Jonathan / Documents / sites / wkux / ct-html-lib / node_modules / gulp-sass / node_modules / node – 同时阅读包括binding.gyp而试图加载binding.gyp

gyp ERR! configuration错误

gyp ERR! 堆栈错误: gyp失败,退出代码:1

gyp ERR! 在ChildProcess.onCpExit(/Users/Jonathan/Documents/sites/wkux/ct-html-lib/node_modules/gulp-sass/node_modules/node-sass/node_modules/pangyp/lib/configure.js:346:16)

gyp ERR! 在emitTwo(events.js:87:13)

gyp ERR! 在ChildProcess.emit(events.js:172:7)

gyp ERR! 在Process.ChildProcess._handle.onexit(internal / child_process.js:200:12)

gyp ERR! 系统达尔文14.5.0

gyp ERR! 命令“/ usr / local / bin / node”“/ Users / Jonathan / Documents / sites / wkux / ct-html-lib / node_modules / gulp-sass / node_modules / node-sass / node_modules / pangyp / bin / node-gyp “”重build“

gyp ERR! cwd / Users / Jonathan / Documents / sites / wkux / ct-html-lib / node_modules / gulp-sass / node_modules / node-sass

gyp ERR! 节点-v v4.0.0

gyp ERR! pangyp -v v2.3.2

gyp ERR! 不好

生成失败

所有其他节点模块似乎已经安装好了。 它与节点的东西,这是在咕噜咕噜,这是导致问题。

       

网上收集的解决方案 "在更新到Node v4.0.0后运行gulp-sass时出错"