Articles of 自制软件

使用自制程序安装新节点后,执行“npm -g update”错误

我正在做一个新的节点通过自制软件安装,并没有安装任何其他模块。 如果我使用npm -g update进行全局更新,则会显示下面显示的所有错误。 怎么了? $ npm -g update npm http GET https://registry.npmjs.org/npm npm http 304 https://registry.npmjs.org/npm npm http GET https://registry.npmjs.org/npm/1.4.6 npm http 304 https://registry.npmjs.org/npm/1.4.6 npm ERR! error rolling back Error: Refusing to delete: /usr/local/bin/npm not in /usr/local/lib/node_modules/npm npm ERR! error rolling back at clobberFail (/usr/local/Cellar/node/0.10.26/lib/node_modules/npm/lib/utils/gently-rm.js:57:12) npm ERR! error rolling back at next (/usr/local/Cellar/node/0.10.26/lib/node_modules/npm/lib/utils/gently-rm.js:43:14) npm […]

node / npm无法通过OSX 10.9.4上的brew进行安装

我认为这是一个新的问题,花了几个小时才弄明白: $ brew install node -v ==> Downloading https://downloads.sf.net/project/machomebrew/Bottles/node- 0.10.31.mavericks.bottle.tar.gz .. npm ERR! Error: EACCES, mkdir '/../.npm/nopt/2.1.2' npm ERR! { [Error: EACCES, mkdir '/../.npm/nopt/2.1.2'] npm ERR! errno: 3, npm ERR! code: 'EACCES',

sudo npm失败,env:node:没有这样的文件或目录

卸载并重新安装节点和npm后,我不能再运行npm作为sudo。 这是在Mac上。 我已经尝试了官方的节点安装程序和brew。 它从我的用户工作,但任何尝试运行sudo npm产生这个错误: $ sudo npm env: node: No such file or directory

无法使用nodebrew安装节点

我用自制软件安装了nodebrew,并试图安装稳定版本的节点。 我正在使用Mac OSX El Capitan版本10.11.1。 $ nodebrew install-binary stable 但是,我收到以下错误: fetch: http://nodejs.org/dist/v5.1.1/node-v5.1.1-darwin-x64.tar.gz Warning: Failed to create the file Warning: /usr/local/Cellar/nodebrew/0.9.2/bin/nodebrew/src/v5.1.1/node- v5.1.1-d Warning: arwin-x64.tar.gz: Not a directory curl: (23) Failed writing body (0 != 987) download faild: http://nodejs.org/dist/v5.1.1/node-v5.1.1-darwin-x64.tar.gz 我试过寻找关于同样的问题,但没有运气的信息。 我该如何解决?

如何酿造安装特定版本的节点?

例如,我想要安装7.9或7.10,但由于webpack node-sass破坏错误,所以要避免使用节点8。 当我运行brew search node这是我所看到的: ❯brewsearch节点leafnode llnode节点✔node-build> node@0.10 node@0.12节点@ 4节点@ 6 nodebrew nodeenv nodenv caskroom / cask / node-profiler 如果你的意思是“节点”:从木桶/木桶迁移到自制/核心。 您可以通过运行brew tap homebrew / core来再次访问它 有检查的节点(我当前的版本是v7.4.0然后node@4 node@0.12 , node@4 node@0.12 , node@4和node@6 ? 我不能完全升级到8的原因是node-sass在webpack中不起作用。 刚刚安装NVM,得到这个疯狂的错误日志: => nvm source string already in /Users/leongaban/.zshrc => Appending bash_completion source string to /Users/leongaban/.zshrc npm ERR! missing: is-path-cwd@^1.0.0, required by […]

节点构build失败

我在Mac OS X 10.6上 – 我试图通过自制程序安装节点,它是一个非描述性的错误信息失败。 我决定克隆节点repo并在目录中build立它。 运行./configure命令之后,输出是: Checking for program g++ or c++ : /usr/bin/g++ Checking for program cpp : /usr/bin/cpp Checking for program ar : /usr/bin/ar Checking for program ranlib : /usr/bin/ranlib Checking for g++ : ok Checking for program gcc or cc : /usr/bin/gcc Checking for gcc : ok Checking for library […]

自制软件安装节点 – 花费时间太长

是否需要永远安装使用Homebrew的node.js? 我尝试了好几次,甚至让它一夜之间跑完了,从来没有完成过。 我现在正在以冗长的模式再次做这件事,它正在打印无尽的“叮当声”。 这不是错误,但我做错了什么,或者我应该只使用包安装程序? 在Retina MacBook Pro上运行OS X 10.8(2.4 GHz,16 GB RAM)

无法运行NPM获取错误:无法find模块“我们在那里”

我刚刚删除节点,并用自制软件重新安装。 我第一次安装没有npm。 然后删除该版本,并与npm安装节点。 安装成功,但现在我不能使用NPM。 任何我尝试与NPM我得到错误 module.js:338 throw err; ^ Error: Cannot find module 'are-we-there-yet' at Function.Module._resolveFilename (module.js:336:15) at Function.Module._load (module.js:286:25) at Module.require (module.js:365:17) at require (module.js:384:17) at Object.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npmlog/log.js:2:16) at Module._compile (module.js:434:26) at Object.Module._extensions..js (module.js:452:10) at Module.load (module.js:355:32) at Function.Module._load (module.js:310:12) at Module.require (module.js:365:17) 我绝对不知道该怎么尝试。 没有npm命令我可以尝试。 我试图删除并重新安装节点与自制软件,但没有奏效。 请帮忙 UPDATE 我看到这个答案: npm不起作用,总是得到这个错误 – >错误:找不到模块'我们在那里' 但解决scheme没有奏效。 我什至没有文件夹 […]

在“brew升级节点”之后,“node -v”显示错误的版本

我升级了我的Node.js版本:> brew upgrade node ,它安装了v5.3.0。 但是当我得到节点的版本:> node -v它显示v0.10.29。 我试过:> brew link –overwrite node但没有工作。 Brew的节点链接到/usr/local/Cellar/node/0.10.29所以我去那里注意到有其他版本的节点,包括我想在/usr/local/Cellar/node/ 。 如何告诉brew将节点链接到/usr/local/Cellar/node/5.3.0 ?

用自制软件更新我的节点js版本

我想在Mac上使用brew来更新我的node.js版本,但是我有这个错误: Error: This command updates brew itself, and does not take formula names. Use 'brew upgrade <formula>'.