Articles of cmd

'$'不被识别为内部或外部命令。“

我已经安装了Node并重新启动了我的电脑,将C:\ Program Files \ nodejs \添加到我的path中,但是当我在命令提示符下运行$ node -version来检查版本时,返回“'$”内部或外部命令,可操作程序或batch file。

utf8 console.log使用node.js输出

我有一个MySQL数据库的utf8信息。 我想用console.log输出到控制台。 但它显示“框”字符,而不是utf8数据。 我在哪里丢失数据? 我该怎么办才能解决这个问题? 从数据库读取数据时出现问题? (使用felixge-node-mysql-v0.9.5-1)或输出到控制台? (使用console.log)也许它的控制台本身(Windows命令窗口设置为字体“Lucida控制台”) 谢谢。 更新:我现在相信它的Windows命令窗口的字体的问题。 当我使用PowerShell窗口运行相同的节点脚本时,我看到不同的字符,看起来不像我所期望的。 无论谁,当我尝试粘贴到这个浏览器窗口,他们突然改变到正确的字体和字符。

Karma不是从cmd开始的

有一个图书馆噶玛 。 Node.js的版本 – 0.10.26。 这些指令表示在命令行上创buildconfiguration文件以执行命令: karma init 但是,如果在执行此命令时显示错误: "Karma" is not an internal or external command, operable program or batch file. 在“path”中将环境variables设置为“npm”path和“karma / bin” C:\Users\username\AppData\Roaming\npm; C:\Users\username\AppData\Roaming\npm\node_modules\karma\bin Node.js和Karma重新安装 – 没有帮助 请告诉我,如何解决这个问题?

永远nodejs:文件config.json未find或无效

我有一个奇怪的问题与nodejs永远。 我已经将iodocs克隆到/ home / user / iodocs 如果我从iodocs目录永远开始: user@ubuntu:~/iodocs$ forever start app.js 一切工作正常。 如果我尝试从另一个目录永远开始,例如: user@ubuntu:~$ forever start –sourceDir /home/user/iodocs/ app.js warn: –minUptime not set. Defaulting to: 1000ms warn: –spinSleepTime not set. Your script will exit if it does not stay up for at least 1000ms info: Forever processing file: app.js 在日志文件中我看到: user@ubuntu:~$ forever logs info: […]

npm安装canvas:错误MSB4019

我正在尝试为我构build的项目安装节点包。 当我告诉node-package-manager安装canvas时 ,命令提示符显示下面的屏幕截图中的错误。 我花了一个星期的时间试图弄清楚这一点。 在大多数在线的地方,他们build议安装Visual Studio C ++和Cairo。 我已经完成了安装Visual Studio快速版,并将开罗的内容复制到一个GTK文件夹。 我也安装了node-gyp并更新了它,但是我仍然从命令提示符得到相同的响应。 我也尝试使用这个代码npm install –msvs_version=2013 ,这个代码npm install canvas –msvs_version=2013 有什么我错过了吗? 谢谢

如何在Visual Studio中使用cmder mini而不是默认cmd(node.js)?

当我在Visual Studio 2013中运行我的node.js应用程序,然后启动默认控制台(cmd)。 我更喜欢CMDER MINI ,如何将默认控制台更改为我的Visual Studio中的cmder mini?

Nodejs在启动时总是打印一个'a'

我的Nodejs有一个很奇怪的问题。 当在cmd窗口运行时,所有'node'和'npm'命令将首先在预期的输出之前打印一个'a'。 如下所示: 我该如何解决? 在重新安装T_T后仍然存在问题

Gulp / Node.js错误:连接ECONNREFUSED

我目前正在使用WAMP运行本地服务器,并且正在尝试设置Gulp.js. 这里是我的gulpfile的内容: var gulp = require('gulp'), sass = require('gulp-ruby-sass'), autoprefixer = require('gulp-autoprefixer'), minifycss = require('gulp-minify-css'), minifyhtml = require('gulp-minify-html'), jshint = require('gulp-jshint'), uglify = require('gulp-uglify'), imagemin = require('gulp-imagemin'), rename = require('gulp-rename'), clean = require('gulp-clean'), concat = require('gulp-concat'), notify = require('gulp-notify'), cache = require('gulp-cache'), livereload = require('gulp-livereload'), lr = require('tiny-lr'), server = lr(); gulp.task('styles', function() { gulp.src('src/styles/main.scss') […]

安装带凉亭的包装

我find了一个日历,我需要安装与鲍尔,但首先我不得不安装节点,npm,git.Ifind节点和git在networking上,我已经安装了巫师。如果我想使用鲍尔我必须安装它: $ npm install -g bower 但是我得到这个错误: SyntaxError: Unexpected identifier at Object.exports.createScript (vm.js:44:10) at REPLServer.defaultEval (repl.js:117:23) at bound (domain.js:254:14) at REPLServer.runBound [as eval] (domain.js:267:12) at REPLServer.<anonymous> (repl.js:279:12) at REPLServer.emit (events.js:107:17) at REPLServer.Interface._onLine (readline.js:214:10) at REPLServer.Interface._line (readline.js:553:8) at REPLServer.Interface._ttyWrite (readline.js:830:14) at ReadStream.onkeypress (readline.js:109:10) > 如果我尝试直接安装包,我已经使用: $ bower install fullcalendar 但它给了我同样的错误.. 我已经从凉亭和日历教程那些命令,但我是新的这些东西,我真的不知道什么是错的或我必须做什么。

Node.js-“npm install express”错误:0906D06C:PEM例程:PEM_read_bio npm

我已经安装了node.js,并且安装了npm。 在我的Windows命令提示符下,当我写“npm install express”时,它给了我下面的错误。如何解决这个问题? C:\ Users> npm -v 2.11.2 C:\ Users> npm install express npm ERR! Windows_NT 6.1.7601 npm ERR! argv“C:\ Program Files \ nodejs \\ node.exe”“C:\ Program Files \ nodejs \ node_modules \ npm \ bin \ npm-cli.js”“install”“express” npm ERR! 节点v0.12.5 npm ERR! npm v2.11.2 npm ERR! 错误:0906D06C:PEM例程:PEM_read_bio:无起始行 npm ERR! npm ERR! 如果您需要帮助,您可以在以下url报告此错误:npm ERR! […]