Articles of json

如何不敏感地searchJSON文件的关键情况

我有一个像下面的JSON对象, "Data Center": { "TMSLevel2": { "Comp-NX2/4/5/6K": "NX2/4/5/6K", "Comp-NX3K": "NX3K", "Comp-NX7K": "NX7K", "Comp-NX9K": "NX9K", "Comp-ACI": "ACI" } } 我将该文件命名为map.js ,并通过Node JS的var map = require ('./map.js')将其导入。 我正在访问它像console.log(map["Data center"]["TMSLevel2"][name]) 。 现在名称是"Comp-NX3K"或"Comp-NX3k"或"Comp-nx3K" 。 当它是"Comp-NX3K"它打印相应的值。 但是,如果是"Comp-nx3K"则打印"undefined"因为没有匹配的值。 如何解决?

我怎样才能通过一个JSON对象的数组循环?

我有JSON数据,我需要循环。 数据在标题为“people.json”的文件中,结构如下: [{"firstname":"John","lastname":"Smith","age":"40"},{"firstname":"Bill","lastname":"Jones","age":"40"}, …] 我想读取这个文件中的每个对象并保存(我使用mongoose)。 这是我到目前为止: var fs = require('fs'); var Person = require('../models/people'); fs.readFile('./people.json', 'utf8', function (err,data) { var i; for(i = 0; i < data.length; i++) { var newPerson = new Person(); newPerson.firstname = data[i].firstname; newPerson.lastname = data[i].lastname; newPerson.age = data[i].age; newPerson.save(function (err) {}); } }); 我无法得到这个工作,虽然。 我究竟做错了什么?

在这个package.json文件中需要改变什么来使用npm 0.3.0?

试图使用一个库,但得到这个错误… npm ERR! JSON.parse Failed to parse package.json data. npm ERR! JSON.parse Note that package.json must be actual JSON, not npm ERR! JSON.parse just a JavaScript object. npm ERR! JSON.parse npm ERR! JSON.parse This changed in npm 0.3.0, and is not a bug in npm. npm ERR! JSON.parse Tell the package author to fix their […]

在查询string中发布嵌套的对象 – Node.js

我的代码试图从我的本地Node.js服务器发布数据到Coldfusion API。 我已经设法与API通信,并通过请求头进行身份validation。 然而,我实际上很难通过我的JSON对象,因为我无法得到正确的结构。 API不接受请求模块的JSON选项,所以这是我最简单的select。 该API期待以下内容: { 'source': { 'customer': { 'customerlogin': 'myusername', 'customerpassword': 'mypassword', } } } 我的代码工作,如果我硬编码下面的身体参数(从别人的成功后)到我的文章。 var Jrequest = require('request'); var options = { uri: 'http://myAPI/customerSSO.json', headers: {'Content-Type': 'application/x-www-form-urlencoded', 'Authorization': something', 'Timestamp': timestamp}, method: 'POST', body: 'source=%7B%0D%0A++%22customer%22%3A+%7B%0D%0A++++%22customerlogin%22%3A+%22myusername%22%2C%0D%0A++++%22customerpassword%22%3A+%22mypassword%22%2C%0D%0A%09%22success%22%3A+%22%22%0D%0A++%7D%0D%0A%7D' // Working }; Jrequest(options, function (error, response, body){ res.send(body); }); 如果我通过其他方式发送JSON,例如json.stringify(),则以“源是必需的但未定义的”为由拒绝。 所以我想我的问题是,在node.js中,我怎么把JSON变成看起来像这样的东西 'source=%7B%0D%0A++%22customer%22%3A+%7B%0D%0A++++%22customerlogin%22%3A+%22myusername%22%2C%0D%0A++++%22customerpassword%22%3A+%22mypassword%22%2C%0D%0A%09%22success%22%3A+%22%22%0D%0A++%7D%0D%0A%7D' 还是我忽略了另一种select? 如果我使用了错误的术语,谢谢你的帮助和道歉。

使用Node.js ENOTFOUNDparsingSDK JavaScript

所以我想在Parse上获取大量的数据,我发现一个很好的解决方法就是做一个recursion函数:当数据成功find时,启动另一个请求。 我这样做的方式非常简单: var containedLimit = 1000, // Also tried with 500, 300, and 100 parseUsersWaiting = { // A lot of Users }, parseUsers = {}, // Recipt for Users getPlayers = function (containedIn) { var count = 0; if (containedIn == undefined) { containedIn = []; for (var i in parseUsersWaiting) { count++; if […]

在节点js中用Avro序列化数据

我想序列化来自JSON对象的数据,并通过networking发送给kafka作为结束。 现在,我在文件中有一个avro模式,确定发送给日志系统的kafka所需的字段: {"namespace": "com.company.wr.messages", "type": "record", "name": "Log", "fields": [ {"name": "timestamp", "type": "long"}, {"name": "source", "type": "string"}, {"name": "version", "type": "string"}, {"name": "ipAddress", "type": "string"}, {"name": "name", "type": "string"}, {"name": "level", "type": "string"}, {"name": "errorCode", "type": "string"}, {"name": "message", "type": "string"} ] } 我正在使用一个节点包“avro-schema”,我尝试了其他的,但是没有一个能够正常工作,我只需要从节点js中以一种方式进行序列化。

如何在VSCode中将环境variables添加到launch.json中

在node.js项目中使用新的VSCode编辑器。 我正在尝试通过编辑launch.json文件来configuration我的“启动”configuration文件进行debugging。 我需要设置一个连接string作为一个环境variables。 根据launch.json文件中的注释: // Environment variables passed to the program. "env": { } 我曾尝试添加我的环境variables,如下所示: "env": { "CONNECTION_STRING": "Data Source=server;Initial Catalog=catalog;User ID=uid;Password=pwd;MultipleActiveResultSets=true" } 这会导致错误,当我尝试启动我的应用程序; “OpenDebug进程意外终止”。 我还没有find任何可以解释问题的日志文件等。 我知道这个应用程序工作正常,当我设置环境variables,并从标准的命令提示符启动我的应用程序。 如果我在launch.json文件中注释掉我的variables,该应用程序也可以正常运行; 我只是无法连接到数据库。 我假设我在launch.json文件中使用了错误的格式,但我还没有find任何方法来使这个工作。 有任何想法吗?

npm安装错误 – 无效的package.json

我正在使用这个教程来理解在Node.js中实现oauth2。 这是我的package.json: { "name": "application-name", "version": "0.0.1", "private": true, "scripts": { "start": "coffee -w server.coffee" }, "dependencies": { "express": "3.3.4", "jade": "*", "coffee-script": "latest", "passport-http": "latest", "passport-http-bearer": "latest", "passport-oauth2-client-password": "latest", "oauth2orize": "latest", "debug" "~0.7.2" } } 我收到错误: npm ERR! install Couldn't read dependencies npm ERR! Failed to parse json npm ERR! Unexpected string npm ERR! […]

nodejs中的base64 JSON编码string

如何在nodejs中创buildbase64 JSON编码的string? 我试了这个,但没有奏效。 var buff = new Buffer({"hello":"world"}).toString("base64"); 是这个吗? var buff = new Buffer(JSON.stringify({"hello":"world"})).toString("base64");

在执行“npm install”之后安装了太多的npm模块,

我的package.json : { "name": "thumbnaillist-gulp", "version": "1.0.0", "description": "", "main": "index.js", "scripts": { "test": "echo \"Error: no test specified\" && exit 1" }, "author": "", "license": "ISC", "dependencies": { "browserify": "^12.0.1", "gulp": "^3.9.0", "gulp-concat": "^2.6.0", "gulp-react": "^3.1.0", "gulp-util": "^3.0.7", "react": "^0.13.3", "react-script-loader": "0.0.1", "reactify": "^1.1.1", "vinyl-source-stream": "^1.1.0", "watchify": "^3.6.1" } } 奇怪的是,在执行“npm install”之后,除了dependencies域中列出的模块之外,还安装了其他模块,比如 drwxr-xr-x 14 […]