Articles of mongoskin

mongodb是否只运行MongoDB版本1.4以上?

我想了解nodejs,express和mongodb我正在运行mongodb v 2.0.6和最新的nodejs和expression并试图通过mongoskin连接快速应用程序与mongodb。 问题是: npm ERR! peerinvalid The package mongodb does not satisfy its siblings' peerDependencies requirements! npm ERR! peerinvalid Peer mongoskin@1.4.13 wants mongodb@~1.4 这是否意味着mongoskin只能使用mongodb v 1.4? 这个版本对我来说是旧的(现在是3)

MongoDB连接不断增加

我一直在打我的连接限制,但httpstream量保持一致。 我使用MMS来分析我的mongod进程,并看到连接数不断上升: 我为Node.js(Express)使用mongoskin包装器。 我有一个自定义路由中间件,在执行其他路由之前连接到mongo数据库: var _connect = function(req, res, next) { res.db = mongoskin.db(_us.sprintf( '%s:%s@localhost:27017/%s?auto_reconnect', app.set('mongoDbUser'), app.set('mongoDbPw'), app.set('mongoDb') )); next(); }; 难道我做错了什么? 我应该如何打开和closures连接?

MongoError:驱动程序与此服务器版本不兼容

我刚刚安装了Mongo,Node等,当我尝试通过我的nodejs服务器更新数据库时,出现此错误: MongoError: driver is incompatible with this server version 这里是我有的版本: 节点 v0.12.2(最新版本是v0.12.3) Express v4.12.4(最新版本是v4.12.4) Mongodb v3.0.3(最新版本是v3.0.3) Mongodb Node.js驱动程序 v2.0.33(最新版本是v2.0.33) Mongoskin v1.3.23(最新版本是v1.3.23) 我有最新版本的一切,我已经search了节点的mongodb驱动程序的git来找出哪个版本的mongodb支持,但我找不到什么:( 我还读了其他SO问题,它说要更新您的mongodb,但我的是最新的版本! 任何帮助?