Articles of node sass

Openshift3构build失败意外

我有一个node.js项目,我试图部署到Openshift Online 3.我的项目有几个依赖项,我认为节点sass库可能是问题。 通常,构build在尝试从github下载二进制文件或在成功下载后立即失败。 这是我得到的详细日志 Cloning "https://github.com/csutorasa/UI-toolkit" … I1002 17:46:11.413243 1 source.go:240] Cloning source from https://github.com/csutorasa/UI-toolkit Commit: 177c8bde324d9dcd07270caa11c2bdc1138bf332 (Build script fix) Author: Ármin Csutorás <csutorasa@gmail.com> Date: Mon Oct 2 00:00:54 2017 +0200 I1002 17:46:12.028219 1 cfg.go:39] Locating docker auth for image registry.access.redhat.com/rhscl/nodejs-6-rhel7@sha256:b0b80d7bb0a1d69ef513a063c5fb3b074b02f699fd5437051233932dae7c864a and type PULL_DOCKERCFG_PATH I1002 17:46:12.028246 1 cfg.go:49] Getting docker auth in paths : […]

我的系统上更新的节点,现在grunt不会在npm项目中运行

我最近更新了我的电脑上的节点到0.12.4。 而这似乎已经做了一些项目,我正在node.js express.js工作。 据我所知,似乎现在正在运行的节点版本和node_modules之间出现了一种兼容性问题。 我用Git回到这个项目的早期版本(版本工作正常),现在他们也不工作。 我的电脑正在运行:OSX Yosemite 10.10.3节点:0.12.4 npm:2.11.3 我的项目依赖于我的package.json文件: "dependencies": { "body-parser": "~1.8.1", "cookie-parser": "~1.3.3", "debug": "~2.0.0", "express": "~4.9.0", "grunt": "^0.4.5", "grunt-sass": "^0.17.0", "jade": "~1.6.0", "morgan": "~1.3.0", "node-sass": "^1.2.3", "serve-favicon": "~2.1.3" }, "devDependencies": { "grunt-contrib-watch": "^0.6.1" } 问题:当我在terminal运行grunt时,我得到错误告诉我: Loading "sass.js" tasks…ERROR >> Error: Cannot find module 'node-sass' Warning: Task "sass" not found. Use –force […]

不能为Ionic安装node-sass

我正在尝试安装使用Ionic的node-sass,但这是不可能的。 我使用node v4.0.0和npm 3.8.0 node v4.0.0 ,当我运行sudo npm install -g node-sass我得到这个错误 $ sudo npm install -g node-sass npm WARN弃用npmconf@2.1.2:这个包已经重新集成到npm中,现在已经过时了npm npm WARN弃用lodash@1.0.2:lodash @ /home/xx/.nvm/versions/node/v4.0.0/lib/node_modules/node-sass/bin/node-sass > node-sass@3.4.2安装/home/xx/.nvm/versions/node/v4.0.0/lib/node_modules/node-sass >节点脚本/ install.js module.js:338 扔呃; ^ 错误:无法find模块'/home/xx/.nvm/versions/node/v4.0.0/lib/node_modules/node-sass/scripts/install.js' 在Function.Module._resolveFilename(module.js:336:15) 在Function.Module._load(module.js:278:25) 在Function.Module.runMain(module.js:501:10) 在启动(node.js:129:16) 在node.js:814:3 /home/xx/.nvm/versions/node/v4.0.0/lib └──(空) npm ERR! Linux 4.1.18-2-MANJARO npm ERR! argv“/home/xx/.nvm/versions/node/v4.0.0/bin/node”“/home/xx/.nvm/versions/node/v4.0.0/bin/npm”“install”“-g” “节点萨斯” npm ERR! 节点v4.0.0 npm ERR! npm v3.8.0 npm ERR! […]

NPM Angular ERR! peerInvalid / peerDependencies要求

在这个package.json上运行npm install { "author": ", Inc.", "name": "-angular2-template", "version": "0.2.0", "description": "Angular 2 Project Template. Webpack, ES6, Sass, Karma.", "bugs": { "url": "https://dev..net//-angular-template/issues" }, "repository": { "type": "git", "url": "git@dev..net:/-angular-template.git" }, "scripts": { "start": "concurrently -k -r \"npm run webpack:w\" \"npm run sass:w\" \"npm run lite\"", "build": "NODE_ENV='production' npm run webpack:b && npm run sass:b", […]

node-sass在Jenkins上安装失败

我试图设置Jenkins来运行Gulp,但是在尝试安装node-sass(gulp-sass插件的依赖)时,它仍然失败。 问题似乎是节点在安装过程中找不到脚本文件。 我确认脚本确实存在于项目库中。 当我在服务器上本地提取回购并安装时,它安装时没有问题。 这让我觉得这是jenkins相关的环境问题。 这是错误输出: > node-sass@2.1.1 install /root/.jenkins/jobs/odyssey-frontend/workspace/node_modules/gulp-sass/node_modules/node-sass > node scripts/install.js module.js:338 throw err; ^ Error: Cannot find module '/root/.jenkins/jobs/odyssey-frontend/workspace/node_modules/gulp-sass/node_modules/node-sass/scripts/install.js' at Function.Module._resolveFilename (module.js:336:15) at Function.Module._load (module.js:278:25) at Function.Module.runMain (module.js:501:10) at startup (node.js:129:16) at node.js:814:3 npm ERR! Linux 3.14.35-28.38.amzn1.x86_64 npm ERR! argv "node" "/home/ec2-user/.linuxbrew/bin/npm" "install" "–production" npm ERR! node v0.12.2 npm ERR! npm v2.7.6 […]

用nodemon和node-sass编译scss

我正在玩node.js,express和node-sass,并用nodemon监视文件更改。 我将这一点添加到app.js编译scss(根据节点sass文档),但它没有做任何事情。 我想在每次修改项目时nodemon运行app.js的时候编译sass。 我不确定它是否会像这样的nodemon工作,但只是在没有nodemon的控制台中运行节点app.js什么都不做,所以它一定是我做错了。 APP.JS文件 /** * Module dependencies. */ var express = require('express'); var routes = require('./routes'); var user = require('./routes/user'); var http = require('http'); var path = require('path'); var sass = require('node-sass') var app = express(); // all environments app.set('port', process.env.PORT || 3000); app.set('views', path.join(__dirname, 'views')); app.set('view engine', 'ejs'); app.use(express.favicon(__dirname + '/public/favicon.ico')); app.use(express.logger('dev')); […]

尝试安装grunt-sass时,“node build.js”失败

我试图从grunt-contrib-sass切换到grunt-sass,但是我正在运行与grunt包装器模块中的node-sass相关的构build错误。 到目前为止,我已经将节点从0.10.40升级到0.12.7,并切换到Python 2.7以绕过其他一些节点,但这仍然是: $ npm install > node-sass@1.0.3 install /var/www/html/example.com/www/node_modules/grunt-sass/node_modules/node-sass > node build.js child_process: customFds option is deprecated, use stdio instead. make: Entering directory `/var/www/html/example.com/www/node_modules/grunt-sass/node_modules/node-sass/build' CXX(target) Release/obj.target/binding/binding.o cc1plus: error: unrecognized command line option "-std=c++11" cc1plus: error: unrecognized command line option "-std=c++11" make: *** [Release/obj.target/binding/binding.o] Error 1 make: Leaving directory `/var/www/html/example.com/www/node_modules/grunt-sass/node_modules/node-sass/build' gyp ERR! build error gyp […]

为什么我的AWS实例不能安装node-sass pacakage?

我使用Node创build了一个应用程序,并试图使用AWS的Elastic Beanstalk来托pipe它,但是当npm install到达node-sass时,它总是失败。 以下是日志中的错误: 5162错误node-sass@4.5.0 postinstall: node scripts/build.js 5162错误退出状态1 5163错误在node-sass@4.5.0 postinstall脚本'node scripts / build.js'失败。 5163错误请确保您安装了最新版本的node.js和npm。 5163错误如果这样做,这很可能是node-sass软件包的一个问题,5163错误与npm本身无关。 5163错误告诉作者,这在您的系统上失败:5163错误节点脚本/ build.js 5163错误您可以获得有关如何打开此项目的问题的信息:5163错误npm错误node-sass 5163错误或者,如果是没有可用的,你可以通过以下方式得到他们的信息:5163错误npm owner ls node-sass 5163错误上面可能还有其他日志logging输出。 5164 verbose exit [1,true] 这里是我的存储库: https : //github.com/Jacob-Elder/react-socket.io-messaging 这是我的awsconfiguration 我search了这个问题,发现有些人用“–unsafe-perm”标志重新安装了node-sass,但这似乎不是一个权限问题。 我是新来的AWS和编码,所以任何帮助非常感谢!

“没有findlibsass绑定。 尝试重新安装节点sass“

所以今天我试图为StreamMe安装MeepBot,并且遇到这样的错误:“'libsass'绑定找不到,尝试重新安装'node-sass'。 我重新安装了一百万次。 我试过了:“npm un / install –save-dev node-sass”,“npm rebuild node-sass”等。有人能给我一个答案吗? 图片: http : //prntscr.com/axbxu8 PS请记住,我正在使用CentOS 6。

Node.js:由于node-sass和node-gyp,Python没有findexception

突然在我的jenkins环境之一构build已经开始失败,而在本地机器似乎工作正常,因为我已经安装了python, 从日志中,我能够检测到问题是与内部依赖关系是node- gyp v3.5.0从node-sass v3.8.0,当我通过访问这个关于node- gyp的研究并find了Python需要安装的先决条件。 所以我的问题是,我可以安装什么版本的节点sass来绕过这个,或者是有更好的解决scheme,因为我的构build运行良好,直到今天早上在相同的环境。 节点v5.10.1 错误日志 gyp verb check python checking for Python executable "python2" in the PATH gyp verb `which` failed Error: not found: python2 gyp verb `which` failed at getNotFoundError (C:\Program Files (x86)\Jenkins\jobs\NdbSite-hot-fix-Manual-PreBuild\workspace\src\NdbSite.UI\node_modules\which\which.js:13:12) gyp verb `which` failed at F (C:\Program Files (x86)\Jenkins\jobs\NdbSite-hot-fix-Manual-PreBuild\workspace\src\NdbSite.UI\node_modules\which\which.js:68:19) gyp verb `which` failed at E (C:\Program Files […]