Articles of nodeclipse

如何将Github存储库导入到Nodeclipse(Enide)中?

我已经启动并运行了Nodeclipse(Enide Studio),并且可以编辑代码并在Enide中运行一个简单的“Hello World”Node.js应用程序。 然而,我不知道如何从Github导入一个Node.js项目到Enide并在“Node”的angular度下运行它。 有人可以启发我的步骤?

Nodejs应用程序无法在Nodeclipse中运行

我设置了Nodeclipse,并写了一个简单的Hello应用程序。 当我尝试作为节点应用程序运行时,出现以下错误 执行命令行发生exception。 无法运行程序“节点”(在目录“C:\path\到\应用程序”):CreateProcess错误= 2,系统找不到指定的文件 如果我从Nodejs控制台运行,应用程序运行。 有没有一种方法可以使它从Nodeclipse运行?

节点js +错误:听EADDRINUSE +未处理的'错误'事件

我正在使用nodeclipse插件为eclipse来运行我的节点js项目。以下js文件工作正常,但h1标签不工作 。我只能看到一个纯文本.plus我得到这个exception在runtime.please帮助我出。 JavaScript文件 var http = require('http'); http.createServer(function (request, response) { response.writeHead(200, {'Content-Type': 'text/html'}); response.end('<html><body><h1>Home</h1> URL was: ' + request.url + '</body></html>'); }).listen(3000, 'localhost'); console.log('Server running at http://localhost:3000/'); 例外 events.js:72 throw er; // Unhandled 'error' event ^ Error: listen EADDRINUSE at errnoException (net.js:904:11) at Server._listen2 (net.js:1042:14) at listen (net.js:1064:10) at net.js:1146:9 at dns.js:72:18 at process._tickCallback […]

如何在Eclipse中忽略节点shebang错误?

我正在写一些节点命令行工具。 他们都是从行开始的: #!/usr/bin/env node 使用Eclipse Juno和Nodeclipse Node.js插件,这行代码会产生如下所示的错误: 好的,所以#在JavaScript中不是一个有效的注释字符,但它在Linux / UNIX中是一个有效的字符,作为文件中第一行的符号 。 但是我怎样才能设置Eclipse来忽略这个错误? 这对我来说是个问题,因为如果你有错误,代码格式化不起作用。 我必须删除该行。 点击CTRL-SHIFT-F并添加行。 我已经尝试了很多东西并进行了研究,但是我找不到答案。 这里有一个重复的问题, 在hashbang行eclipse javascript语法错误 ,但我的问题有更多的信息。 编辑: 看起来有什么东西添加到jshint允许shebangs在第一行 。 也许我需要更新我的node-eclipse,或者node-eclipse项目需要更新jshint? 我的jshint eclipse集成版本是0.9.6。 我的nodeclipse是0.4.0.20130519 … 我升级到 jshint eclipse集成0.9.9.20131029 nodeclipse 0.7.0.20131101 这没有帮助。 这是我在eclipse中的JSHint版本: 编辑2: 感谢VonC的回答。 但我认为这表明我没有在文件中的BOM。 任何其他的想法? $ od -N 20 -t x1 hello.js 0000000 23 21 2f 75 73 72 2f 62 […]

Eclipse停留在JavaScript文件的复制/剪切上

我安装了Eclipse Kepler和NodeEclipse插件。 对于NodeEclipse的性能原因,我已经禁用JavaScript文件的内容助手。 问题:每当我在JS文件(ctrl + c / ctrl + x)中复制或剪切一些行时,CPU使用率为100%,而eclipse进程占用所有内存(> 1GB)。 我认为一些GC抖动正在发生。 增加JVM最大内存更多是一个选项,但不是1GB足够的日食? 这可能是一些内存泄漏。 这是与Nodeclipse的具体问题? 在Eclipse中有任何解决方法/设置diable? 编辑:当我双击一个variables,CPU泵到100%,3-4秒,下来。 我有标记已经disbled。 这只发生在route / *。js文件而不是公用文件夹中。 调查更多,我发现包含require('<package-name>')注释行解决了这个问题,为什么?