Articles of npm

npm WARN弃用minimatch

如何ii'm试图执行npm安装butit给我这个错误: npm WARN弃用minimatch@2.0.10:请更新至minimatch 3.0.2或更高版本以避免RegExp DoS问题 我正在使用节点v4.1.1 我如何解决这个问题?

Heroku:更新节点版本不起作用

我想更新我的应用程序节点版本Heroku目前它是0.10.40 Heroku应用程序 要更改为我所需的版本,我将package.json文件调整为: { "name": "myapp", "private": true, "engines": { "node": "4.8.4" }, "scripts": { "start": "meteor run" }, "dependencies": { "meteor-node-stubs": "~0.2.0" } } 然后将我的代码部署到heroku应用程序。 但是在通过heroku CLI检查版本时仍然如此 heroku run node -v -a myapp 该版本不更新,它仍然使用较旧的版本。 任何帮助!

npm无法安装fabric-ca-client

我们在CentOS 7.3和RHEL 7.3上都遇到了问题,试图安装最新的NodeJs fabric-ca-client 这是一个完整的清单: sudo npm install -g fabric-ca-client@1.0.0 > x509@0.3.2 install /usr/lib/node_modules/fabric-ca-client/node_modules/x509 > node-gyp rebuild gyp ERR! clean error gyp ERR! stack Error: EACCES: permission denied, rmdir 'build' gyp ERR! stack at Error (native) gyp ERR! System Linux 3.10.0-514.el7.x86_64 gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /usr/lib/node_modules/fabric-ca-client/node_modules/x509 gyp ERR! node -v […]

eslint – 修正由npm运行时不工作

当我运行npm时,eslint –fix选项不起作用。 这是我的package.json脚本 "scripts": { "start": "nodemon ./server.js –exec babel-node", "lint": "eslint ./data/* –format html –output-file ./finalresult.html –fix ; exit 0" } 当我运行它使用命令npm运行lint报告正在生成,但没有修复。 但是如果我运行相同的命令 eslint ./data/* –format html –output-file ./finalresult.html –fix 从控制台它正在修复后生成报告。为什么这样? 我做错了什么? 谁能帮帮我吗

NPM和devDependencies之间有什么区别?

下面的问题是指我没有发布到npm的项目。 在NPM 3中,如果我在devDependencies有一个包并且运行了devDependencies (没有–development ),那么npm-shrinkwrap.json –development将不包含devDependencies的包。 但是在NPM 5中, dependencies和devDependencies中的package-lock.json被添加到package-lock.json , devDependencies中的包含"dev": true 。 那么,如果我只是使用npm install x来添加软件包,并且使用npm install来安装所有的软件,比如一个构build服务器,那么dependencies列出的软件包与devDependencies列出的软件包是devDependencies呢?

如何将node_modules文件夹部署到生产服务器?

我在PHP(LAMP服务器)中制作一个非常简单的网站 (如pastebin)。 这个网站使用jquery和bootstrap。 我之前使用了bower ,但是我想切换到使用npm 。 我的目录结构是这样的: 上市 HTML 的index.php node_modules jQuery的 DIST 的jquery.js 加上几十个不必要的文件夹 引导 … 当我使用bower时,我曾经将整个bower_components文件夹上传到我的FTP服务器。 我的node_modules文件夹相当大,包含数百个文件,所以我不知道是否应该上传它? 我想我可以上传package.json并在上传后在我的web服务器的命令行上运行npm install ,但是会暴露node_modules文件夹给公众构成潜在的安全隐患?

http.get()方法和var request = require('request')有什么区别

我是新来的节点JS,在learnyounode的nodeJS练习no.8中,我的解决scheme产生相同的require结果。我很困惑什么时候使用http.get和Request 目标 :编写一个执行HTTP GET请求的程序给你提供的URL 作为第一个命令行参数。 从服务器收集所有数据(不是 只是第一个“数据”事件),然后写两行到控制台 (标准输出)。 你写的第一行应该只是一个表示数字的整数 从服务器收到的字符。 第二行应该包含 完成服务器发送的string。 官方解决scheme var http = require('http') var bl = require('bl') http.get(process.argv[2], function (response) { response.pipe(bl(function (err, data) { if (err) return console.error(err) data = data.toString() console.log(data.length) console.log(data) })) }) 我的解决scheme var request=require('request') request(process.argv[2],function(err,response,body){ console.log(body.length); console.log(body); })

npm / Frameworks /如何知道应该使用哪个版本?

我面对的问题是, 我永远不知道哪个版本的npm,Ionic等, 我应该安装 。 例如: “哦,一个新的Ionic CLI版本在这里,让我们安装它” 安装CLI v3.9.0 “哦,我的项目中没有任何工作了,Mhhh让我们更新框架” 安装离子angular3.6.0 “哦,让CLI工作我需要一个5以上的npm版本” 安装新的npm版本 而且毕竟更新什么都 行不通 ,因为这个版本的bla bla bla 不适用于那个bla bla bla的版本。 我们都知道斗争。 但是,在所有的论坛中,总有一些人似乎知道你需要从什么框架安装哪个版本才能让你的项目运行。 那里也有很多编程教程。 但是首先我们需要学习结构,以及所有框架和客户如何相互关联和合作。 我和其他人一样,想知道如何知道我不应该安装新的更新,因为它与其他框架不兼容。 但是,如果没有我们初学者的知识,我们会立即安装更新,而不知道是否会更好。 这是另一个例子: 如果不知道Ionic 3.6需要低于5的npm才能完美工作,则可以安装npm 5+。 现在你想为你的项目安装一个插件,并在例子中得到一个GYP错误。 那么不知道你的NPM版本只是导致错误一个初学者会浪费这么多的时间search如何reslove GYP错误。 逻辑。 因为在他安装npm 5+之前,他应该怎么知道他必须等待更新版本的Ionic 所以,请帮助我和许多其他人,解释并让我们知道我们需要知道的信息的位置和方式,所以最终初学者也是知道如何做“版本控制”的专家。

Angular 4生产部署工作stream程

我和一位同事讨论了如何将angular度4应用程序部署到生产服务器。 如果可能的话,希望从社区那里得到实际的build议和指导。 前提1 在生产服务器上, git pull npm install {set up production configuration} ng build –prod –aot 在生产服务器上构build和编译 生产服务器硬件规格需要支持构build过程 托pipe服务器上需要添加空间以容纳node_modules git repo master分支没有编译代码,因此是一个“clean source repo” 前提2 在生产服务器上, git pull 在本地开发工作站上build立和编译生产代码将会更快 git repo master分支将保留已编译代码的部署快照 生产服务器仍然是一个有限的空间的128MB的RAM,因为它是服务的HTML,JS和CSS。 当需要进行恢复或缩放时,可以更快部署到另一台服务器,因为它只是一个混帐

我是否应该将所有子包保存在package.json中的单个版本中?

我的项目使用的第三方库已经将其function分割为多个导入的包,以便项目可以安装它所需的东西。 在package.json中,不同的子包有几个条目,比如… "dependencies": { "@lib/dogs": "^1.0.3", "@lib/cats": "^1.0.3", "@lib/iguanas": "^1.0.3" …lots more of the same… } 如果其中一个子包通过semver-range-picking安装不同的版本号,而另一个开发人员通过在一个子包上递增版本来解决问题,我不想花时间考虑兼容性问题。 如果子包版本不同步,我怀疑存在一些bug的风险,即使包维护者的意图是尊重破坏版本变化的含义。 只是默认情况下,所有的子软件包都在相同的版本上似乎更简单。 我应该尝试执行(或者至less是提升)子包具有相同的版本吗?