Articles of npm

npm全球名单不断变化

非常新的npm和node.js 我有一个奇怪的问题,每当我键入 npm list -g –depth=0 它总是显示我目前所在的包,大多数情况下它显示为空。 纠正我,如果我错了,但我认为你的全球path应该是固定的,这是你可以安装所有在你的命令提示符工作正确的包的地方? 另外,当我键入node -v它工作正常,但它不显示为全局包。 我已经坚持了几天,希望有人能够帮助。 例如,这是我得到的。 F:\node.js>node -v v8.9.0 F:\node.js>npm list -g –depth=0 F:\node.js +– error: ENOENT: no such file or directory, open 'F:\node.js\node_modules\etc\package.json `– npm@5.5.1 npm ERR! error in F:\node.js\node_modules\etc: ENOENT: no such file or directory, open 'F:\node.js\nod e_modules\etc\package.json' F:\node.js>cd programs F:\node.js\programs>npm list -g –depth=0 F:\node.js\programs `– (empty)

在使用中使用Angular 4中的node_module(网站刮板)失败

目前我正在尝试将node_module“网站刮板”[1]添加到我的Angular 4项目中。 我通过“npm install website-scraper -save”下载安装模块。 在我的组件我导入模块“导入*作为刮刀从'网站刮板'”。 到目前为止,所有东西都按预期编译 如果我现在只是添加“console.log(Scraper)”在我的组件的某处,我得到警告[3],我的浏览器抛出错误[2] 有人可以启发我,出了什么事? 我使用节点8.9.0和npm 5.5.1。 无论如何,我尝试多个furhter(旧)版本的节点和npm导致相同的行为。 任何帮助表示赞赏。 提前致谢。 [1] https://www.npmjs.com/package/website-scraper [2] graceful-fs.js:166 Uncaught TypeError: Cannot read property 'prototype' of undefined at patch (graceful-fs.js:166) at Object.eval (graceful-fs.js:27) at eval (graceful-fs.js:262) at Object…/../../../graceful-fs/graceful-fs.js (vendor.bundle.js:884) at __webpack_require__ (inline.bundle.js:55) at eval (index.js:4) at Object…/../../../fs-extra/lib/fs/index.js (vendor.bundle.js:726) at __webpack_require__ (inline.bundle.js:55) at eval (index.js:8) at […]

如何使用Express Swagger Generator在同一路线上定义多个操作

我使用npm软件包express-swagger-generator ,当我定义2路由像这样: /** * @group Users – operations about user * @route GET /users * @route POST /users */ 它只显示POST路线,而不是像这样的GET路线 如果我切换它们,它只显示GET路线,同样使用@group标记两次在分开的地方定义它们。 如何使我的api文档中显示的POST和GETpath都在/ users上?

要求“d3-select-multi”作为节点模块不工作

我通过npm安装了d3,并直接要求在我的脚本中(出于某种原因) 所以: npm install d3 接着 var d3 = require("d3"); 工作正常。 现在的问题是,我需要“d3select多”模块。 我也通过npm安装它 npm install d3-selection-multi 在d3-Doku我读,你可能需要不同的模块,如: var d3 = Object.assign({}, require("d3-format"), require("d3-geo"), require("d3-geo-projection")); 我改变了我的需要,这将是有标准的D3包(工作已经上面),并添加D3select多。 var d3 = Object.assign({}, require("d3"), require("d3-selection-multi")); 那不行。 所以我通过打印出结果对象来testing它: console.log(d3) 结果是正确的: {version: "4.11.0", bisect: ƒ, bisectRight: ƒ, bisectLeft: ƒ, ascending: ƒ, …} 但是“d3-selection-multi”模块不存在。 我可以看到,因为它不能识别d3.selectAll().styles作为函数。 我尝试了以下:而不是 var d3 = Object.assign({}, require("d3"), require("d3-selection-multi")); […]

找不到模块“encryption”

我正在尝试执行二重奏 ,但当我尝试使用它,我得到这个错误: import Duo from 'duo_web'; 我安装了meteor npm install duo_web –save在Windows 10 , node v8.9.0 , npm v5.5.1 。 我知道duo_nodejs使用crypto模块,也安装了它。 的package.json "crypto": "^1.0.1", "duo_web": "^1.0.2",

“尝试进行NPM发布时,不能使用”新build“类的构造函数

我有一个项目,我试图发布为一个NPM模块。 这一切都在我的电脑上正确运行,当我将其导入到不同的文件夹中时,我可以毫无问题地使用它,但npm发布给了我这个: npm ERR! Class constructor cannot be invoked without 'new' npm ERR! A complete log of this run can be found in: npm ERR! /Users/forrest/.npm/_logs/2017-11-09T13_21_57_362Z-debug.log 老实说,我什至不知道在哪里寻找这种错误 – 我敢肯定我的代码不会丢失任何“新”关键字,因为它在我尝试发布之前正确运行。 如果这是一个NPM的具体问题,我没有能够search任何东西。 我怎样才能解决这个错误,并成功发布? 如果没有,那么这个问题是什么样的呢?我应该看看我的代码在哪里? 这是那个日志文件: 0 info it worked if it ends with ok 1 verbose cli [ '/usr/local/bin/node', '/usr/local/bin/npm', 'publish' ] 2 info using npm@5.5.1 3 […]

将Webpack添加到现有的React应用程序

所以我使用create-react-app构build了第一个应用create-react-app 。 它默认使用npmbuild设,本地运行等… 我想要做的是转移到使用Webpack,但不打破现有的设置,并做了一些谷歌search,但没有开始,一步一步地走,所以我可以更好地感受它正在做什么,去哪里。 也希望也使用webpack-dev-server合并。 这就是说,我希望你们有一些build议,也许还指出了一些很好的教程,为这个前进? 非常感谢。

`npm start`抱怨“缺less脚本:开始”,没有运行节点

我在我的NPM包中有以下文件: package.json : { "name": "npm-start", "version": "1.0.0", "description": "", "main": "index.js", "scripts": { "test": "echo \"Error: no test specified\" && exit 1" }, "author": "", "license": "ISC" } index.js console.log('Hello world!'); 当我尝试运行npm start ,收到错误消息: > npm start npm ERR! missing script: start 好吧,这是真的: "scripts"对象中没有"start"属性。 但是NPM的CLI文档声明了关于npm start这个: 如果在"scripts"对象上没有指定"start"属性,它将运行node server.js 。 为什么NPM让我失望? 是不是应该在这种情况下调用node ? 我错过了什么吗? (当然,手动调用节点工作正常)。 […]

我得到msg.trim不是一个function,当试图启动与离子的新应用程序

这里是错误: TypeError:msg.trim不是Logger.log中的函数(/usr/local/lib/node_modules/ionic/node_modules/@ionic/cli-utils/lib/utils/logger.js:78:21)在Logger.error (/usr/local/lib/node_modules/ionic/node_modules/@ionic/cli-utils/lib/utils/logger.js:35:14)。 (/usr/local/lib/node_modules/ionic/dist/index.js:186:22)在Generator.throw()被拒绝(/usr/local/lib/node_modules/ionic/node_modules/tslib/tslib.js: 101:69)at 这是我正在运行的命令: $ ionic启动myApp 我的node.js版本是v8.9.1 ,npm是5.5.1 这是我在logger.js文件中find的 log(level, msg) { if (this.shouldLog(level)) { let prefix = this.prefix; if (typeof msg === 'function') { msg = msg(); } if (prefix) { if (typeof prefix === 'function') { prefix = prefix(); } msg = util.format(prefix, msg); } const color = this.getStatusColor(level); const status […]

node.js 9和npm 5.5.1:无法正确运行安装

在将我的项目升级到node.js 9.1.0(和bundle nom 5.5.1)之后,我无法运行install wo错误。 即使日志输出是'详细',我不明白在哪里是问题…帮助欢迎 0 info it worked if it ends with ok 1 verbose cli [ '/usr/local/bin/node', '/usr/local/bin/npm', 'run', 'build' ] 2 info using npm@5.5.1 3 info using node@v9.1.0 4 verbose run-script [ 'prebuild', 'build', 'postbuild' ] 5 info lifecycle shopping-list@1.0.0~prebuild: shopping-list@1.0.0 6 info lifecycle shopping-list@1.0.0~build: shopping-list@1.0.0 7 verbose lifecycle shopping-list@1.0.0~build: unsafe-perm […]