Articles of npm

如何使用私有NPM包与云function?

我正在尝试将应用切换到Firebase,并将后端传输到Firebase云端function。 此应用程序正在使用私有包( @org/name )作为依赖项。 我试过不同的解决scheme,但似乎没有工作: 传递一个NPM_TOKEN env:不可能,因为Firebase限制为小写configuration npm install模块npm install在函数目录中 使用YARN和NPM授权令牌在函数目录中创build一个.npmrc文件 它始终拒绝部署: Deploy Error: Build failed: Module @org/name not found in npm registry Firebase是否支持私人套餐?

确定一个给定的npm包的最stream行的版本?

npmregistry提供程序对最依赖的软件包进行了度量,但是您想要确定给定软件包的最stream行版本 – 是否有可能? 作为一个用户,说我正在考虑升级到react-router^4.0.0 ,但想看看一些采用数字(即运行^3.0.0 vs ^4.0.0的人数),是否有一个方法来做到这一点? 一般来说,一个给定的软件包在过去一个月中下载了50万次,我无法想象它们都是foobar@latest ,所以查看每个版本的下载细节似乎是有用的。 此外,作为一个发布者,假设我有一些发布到npm软件包,并且想知道这些软件包的哪个版本最受用户欢迎。 npm是否为此提供某种types的报告? 当我login并查看已发布的项目时,似乎找不到这些数字。

Node.js的Cluster模块和Learnboost的Cluster模块有什么区别?

Node.js本身有一个叫做Cluster的核心模块(ref: http ://nodejs.org/docs/v0.8.3/api/cluster.html),而且Learnboost发布了一个名为Cluster的模块(ref: http:/ / /learnboost.github.com/cluster/ https://github.com/LearnBoost/cluster )。 这两者如何比较? 他们在某种程度上是相关的吗?

为客户端部署压缩node_modules

我正在使用Node.js在JavaScript中实现一个客户端应用程序。 因为我将在许多机器上部署软件,所以我想尽量减less我分发的软件包的大小。 特别是,我想从node_modules中删除任何不必要的文件。 对于初学者来说,这意味着删除和修剪依赖树,而npm可以为我做的。 但是我也想删除所有的package.json文件和(特别是)任何其他不需要部署的文件。 在我使用的许多软件包中有大量的testing,多个版本的文件(缩小,浏览等)等等。 我只需要运行应用程序实际使用的JavaScript文件。 否则,我将分发几个100Kb的文件,但实际上并没有使用。 我知道node-browserify但我的应用程序将运行在CommonJS环境,而不是一个浏览器,所以我想保持模块分开,并加载require 。 我正在考虑编写一个Grunt插件,它使用required的脚本遍历依赖关系树,在运行时拉出required的JavaScript文件,并将它们写入树结构,以便使用require来加载它们(只需直接加载模块而不需要package.json )。 但是,在我解决之前,我想确保没有人为我做这件事。

Node.js – 使用NVMconfiguration$ NODE_PATH

在用NVM设置Node.js路上,我使用Yeoman时偶然发现了一个错误。 我得到了错误 Cannot find module 'yeoman-generator' 经过一番研究,我在StackOverflow上发现了这个post ,这也是我的问题。 现在我试图这样做,但是我遇到的问题是,我想通过使用NVM在系统上使用不同版本的Node.js。 现在是否可以dynamic改变$ NODE_PATH,如果Node.js版本在NVM的帮助下改变的话? 因为我的$ NODE_PATH目前是空的(这是导致问题)。 $ which node /Users/dschmidt/.nvm/v0.10.35/bin/node $ which npm /Users/dschmidt/.nvm/v0.10.35/bin/npm $ echo $NODE_PATH [empty] 对于我得到的每一个答案都会很高兴。 我search了这个网页,但没有find一个具体的post。

如何以编程方式更新节点模块

我需要使用脚本中的npm更新。 以下是我的代码: var npm = require('npm'); npm.load(function () { npm.commands.outdated({json: true}, function (err, data) { //console.log(data); npm.commands.update(function(err, d){ console.log(d); }); }); }); 当我运行这个脚本的时候,模块会被更新,但是新的版本并没有在package.json中指明。 当我从命令行运行npm update –save-dev ,会更新文件夹和package.json。 请build议如何通过脚本来实现这一点。 如何通过代码使用–save-dev选项?

全局安装NPM软件包时的行为不一致

我试图在Ubuntu(12.04)上安装NPM软件包。 我已经通过Chris Lea的PPA存储库安装了Node.js和NPM。 我正在尝试将Uptime项目部署到我的服务器。 我从GitHub克隆了应用程序,然后尝试以root用户身份安装应用程序依赖项: root@dev:/web/my-application# npm install -g npm http GET https://registry.npmjs.org/mongoose/2.5.11 npm http GET https://registry.npmjs.org/express/2.5.0 npm http GET https://registry.npmjs.org/ejs/0.6.1 npm http GET https://registry.npmjs.org/config/0.4.11 npm http GET https://registry.npmjs.org/async/0.1.18 npm http GET https://registry.npmjs.org/socket.io/0.9.2 npm http 304 https://registry.npmjs.org/ejs/0.6.1 npm http 304 https://registry.npmjs.org/async/0.1.18 npm http 304 https://registry.npmjs.org/mongoose/2.5.11 npm http 304 https://registry.npmjs.org/express/2.5.0 npm http 304 https://registry.npmjs.org/config/0.4.11 npm http […]

PhoneGap – 无法通过npm安装,phonegap不存在

我正在尝试下载并运行PhoneGap。 我已经尝试了3台机器(2个mac,1个windows),我不禁感到好像我做错了什么。 我有nodeJS(v0.10.13)和NPM(1.3.2)安装到最新版本,使用自制软件。 要安装PhoneGap我通过命令行执行以下操作: sudo npm install -g phonegap NPM继续下载大量的软件包并安装时没有任何警告或错误。 安装后,我得到以下,我认为是正确的: npm http 200 https://registry.npmjs.org/asn1/-/asn1-0.1.11.tgz /usr/local/share/npm/bin/phonegap -> /usr/local/share/npm/lib/node_modules/phonegap/bin/phonegap.js phonegap@3.0.0-0.14.0 /usr/local/share/npm/lib/node_modules/phonegap ├── pluralize@0.0.4 ├── colors@0.6.0-1 ├── semver@1.1.0 ├── qrcode-terminal@0.9.4 ├── shelljs@0.1.4 ├── optimist@0.6.0 (wordwrap@0.0.2, minimist@0.0.1) ├── node-static@0.7.0 (colors@0.6.0, mime@1.2.9) ├── phonegap-build@0.8.3 (qrcode-terminal@0.8.0, optimist@0.3.7, shelljs@0.0.9, phonegap-build-api@0.3.3) ├── prompt@0.2.11 (revalidator@0.1.5, pkginfo@0.3.0, read@1.0.5, winston@0.6.2, utile@0.2.0) └── cordova@3.0.0 (ncallbacks@1.0.0, colors@0.6.0, […]

npm ERR! 无效:strip-ansi@0.2.2

使用brew upgrade node : $ node -v v0.10.30 我做了一个npm update -g : $ npm -v 1.4.23 当npm ls -g时有一个ERR: npm ERR! invalid: strip-ansi@0.2.2 /usr/local/lib/node_modules/npm/node_modules/columnify/node_modules/strip-ansi npm ERR! not ok code 0 我该如何解决这个错误?

如何在package.json中强制嵌套的npm依赖关系

我相信这是很常见的问题,但是我仍然找不到可靠的答案。 在我的package.json中,我有依赖项 – “grunt-selenium-webdriver”,它的package.json中列出了一些不能从我们的networking访问的依赖版本(我们正在使用内部有时滞的NPMregistry)。 我想使用当前版本的grunt-selenium-webdriver,但使用不同版本的嵌套依赖。 这有可能吗? PS:我尝试了同行依赖,但它似乎旨在解决另一个问题。