Articles of windows 7 x64

从node.js模块获取D9025警告和C1083错误…我没有想法

首先我必须清楚,我绝不是一个JavaScript大师。我只是非常热心,我喜欢学习新东西。 我正在运行带有SP1的Windows 7 Ultimate x64,Windows更新已打开,node.js是v0.10.22。 我已经用Visual Studio C ++ Express版本2008,2010和2012分别尝试了这个过程,每个.net框架都是按照更新顺序安装的。 我也尝试了最初的干净安装后,每个版本的最新服务包。 所以,从理论上说,我应该在某种程度上已经有了各种可能的组合……而且我仔细检查了环境variables,并且为了每个版本都重新启动,只是为了好的措施。 然而它仍然以同样的方式失败。 我设法跟踪回到尽可能多的模块( node-ant , sails等)中的node-gyp rebuild命令,这会抛出: E:\Temp\node-test\node_modules\node-ant\node_modules\usb>node "C:\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild Build started 2013/12/06 19:46:52. __________________________________________________ Project "E:\Temp\node-test\node_modules\node-ant\node_modules\usb\build\binding.sln" (default targets): Target ValidateSolutionConfiguration: Building solution configuration "Release|x64". Target Build: Target usb_bindings: VCBuild.exe E:\Temp\node-test\node_modules\node-ant\node_modules\usb\build\usb_bindings.vcproj "Release|x64" cl : Command line warning D9025: overriding '/MT' with '/MD' cl : […]

当从npm安装Yeoman时出现ENOENT错误

我正在尝试在cmd中使用以下命令来安装Yeoman: npm install –global yo 我得到以下内容: npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm npm ERR! Windows_NT 6.1.7601 npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\{userdir}\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install" "–global" "yo" npm ERR! node v4.4.4 npm ERR! npm v3.9.0 npm ERR! path C:\{userDIr}\AppData\Roaming\npm\node_modules\yo\lib\cli.js npm ERR! code […]

如何使用pm2来部署到Windows堆栈

环境 开发机器:Windows 7 部署目标:Windows 2012 R2 v7.10.1版本v7.10.1 Git git-bash 2.9.2.windows.1 我正在尝试使用PM2部署一个NodeJS项目 PM2部署 我的PM2生态系统文件 deploy : { production : { user : 'myUser', host : '10.1.1.16', ref : 'origin/master', repo : 'pshakr@bitbucket.org/pjma/adapter.git', path : 'C:\\jhu', 'post-deploy' : 'npm install && pm2 startOrRestart ecosystem.config.js –env production' } } 我在开发机器上打开了GIT-Bash ,在运行configuration文件时出现以下错误 错误 $ pm2 deploy ecosystem.config.js production setup […]

npm在Windows 7上安装restify错误?

我正在尝试使用Node.js构buildREST Web服务,以便在安装后尝试安装restify,然后从http://nodejs.org/和python版本2.5下载并安装node.js版本0.10.29。 C:\Program Files\nodejs>npm install restify 它显示一个错误:“gyp”失败,退出代码:1? 如下图所示,我也search了很多关于这个错误的谷歌,但我无法find解决scheme。

是否有手动安装node.js for Windows 7?

我已经在Mac和其他PC上轻松安装了Node.js,但是现在我在工作的PC限制了.msi文件的运行。 有没有办法在Windows 7上手动安装和configurationnode.js和npm? 我有权访问Powershell。

初学者 – 在Windows 7上使用XAMPP设置Angular应用程序的本地主机

当我使用Visual Studio IIE服务器时,我采用了一个在本地主机上运行的Angular App。 我不想使用Visual Studio,我正在尝试使用XAMPP在本地testing应用程序。 我是一个完整的初学者,我不能让本地主机拿起HTML初始化文件。 我检查了以下内容: Skypeclosures,并且XAMMP中的端口设置为80 HTTPd.conf中的根服务器设置正确(末尾没有斜线) 我对于如何在XAMMP本地主机上工作的angular度感到有点困惑。 我需要得到Yeoman还是咕噜(看到这些应用程序的一些职位,但他们似乎是在命令行环境)。 任何帮助,甚至指向一步一步的设置将是伟大的!

在Windows 7上找不到模块“连接”

请看下面: C:\Program Files\nodejs>npm -g install connect npm http GET https://registry.npmjs.org/connect npm http GET https://registry.npmjs.org/connect npm http GET https://registry.npmjs.org/connect npm http GET https://registry.npmjs.org/finalhandler/0.1.0 npm http GET https://registry.npmjs.org/debug/1.0.4 npm http GET https://registry.npmjs.org/parseurl npm http GET https://registry.npmjs.org/utils-merge/1.0.0 npm http GET https://registry.npmjs.org/utils-merge/1.0.0 npm http GET https://registry.npmjs.org/finalhandler/0.1.0 npm http GET https://registry.npmjs.org/parseurl npm http GET https://registry.npmjs.org/debug/1.0.4 npm http GET https://registry.npmjs.org/utils-merge/1.0.0 npm […]

如何为nodejs安装win32ole(即使node-gyp正常工作)

对不起,我是nodejs的新手。 我想在Windows7下的win32ole中试用win32ole包,但是当我以pipe理员身份打开的命令提示符窗口中运行安装命令npm install win32ole时,popup很多错误。 我的configuration是: Windows 7 64位(版本6.1.7601) Microsoft Visual Studio Express 2015用于Windows桌面 – ENU(imho必须安装20GB软件才能使node-gyp工作如同某个IT模型的失败certificate) Microsoft .NET Framework 4.6 Python 2.7.9和3.4.3都安装了,但是我把python命令指向了2.7.9 nodejs版本4.2.1 npm版本2.14.7 node-gyp 3.0.3 PYTHON环境variables设置为C:\Python27\python.exe 告诉node-gyp在哪里用命令查找Python node-gyp –python C:\Python27\ 告诉npm在哪里可以findPython的命令npm config set python C:\Python27\python.exe 这是控制台输出: C:\Windows\system32 >npm install win32ole Impossibile trovare il percorso specificato. npm WARN engine win32ole@0.1.3: wanted: {"node":">= 0.8.18 && < 0.9.0"} […]

Gulp运行在windows |上运行失败 错误消息:Microsoft JScript编译错误,无效的字符

我在我的Windows 7本地机器上安装Node.js ,因为这个链接说: 安装节点-JS-NPM-窗口 之后,我通过这个命令通过命令行安装了Gulp.js : npm install -g gulp 然后我将这个path添加到环境variables区域: C:\ Users \用户马吉德\应用程序数据\漫游\故宫\ node_modules \一饮而尽\ BIN 现在,当我尝试通过这个命令来运行gulp时: gulp 我得到这个错误: Windows Script Host Line: 1 Char: 1 Error: Invalid character Code: 800A03F6 Source: Microsoft JScript compilation error 我怎样才能解决这个错误,我怎样才能使gulp.js在Windows操作系统上可行? 编辑答案后: 错误仍然存​​在。 我去了这条路: C:\ Users \用户名\应用程序数据\漫游\故宫\ node_modules \一饮而尽\ BIN 在命令行中试过这个命令: node gulp.js install 但它告诉: 没有findgulp文件 你应该知道在前面的步骤中已经安装了gulp(有一些警告) gulp.js的结构是基于Linux的操作系统。 […]

Node.js弃用了对象键

我是node.js的初学者,我正通过教程学习它。 我正确地安装了节点,并用简单的console.log调用进行了testing。 问题是我试图运行这个命令时出现错误: npm-install node-dev -g 我收到一个错误: “npm WARN弃用object-keys@0.2.0:请更新到最新的对象键” 我在Windows 7 64位上运行节点 任何想法可能是错的?