Articles of xcode

安装nodeBB时,发现node-gyp rebuild status 1问题

我正在尝试安装开源论坛系统之一的nodeBB。 当我尝试在这个github页面运行命令。 我得到了下面的错误信息, > mmmagic@0.3.15 install /Users/tyler/Work/forum/NodeBB/node_modules/mmmagic > node-gyp rebuild gyp WARN install got an error, rolling back install gyp ERR! configure error gyp ERR! stack Error: EPERM, utime '/Users/tyler/.node-gyp/0.12.7' gyp ERR! stack at Error (native) gyp ERR! System Darwin 14.4.0 gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /Users/tyler/Work/forum/NodeBB/node_modules/mmmagic gyp ERR! node -v […]

通过TVJS-tvOS调用API JSon

我正在尝试使用tvOS,并且在处理json调用方面有一些小问题。 我必须通过一个API获取一些数据,比方说为了testing,我打电话给这个链接 http://query.yahooapis.com/v1/public/yql?q=select%20item%20from%20weather.forecast%20where%20location%3D%223015%22&format=json 我试图用一些修改这个函数 function getDocument(url) { var templateXHR = new XMLHttpRequest(); templateXHR.responseType = "json"; templateXHR.open("GET", url, true); templateXHR.send(); return templateXHR; } 但没有解决。 任何提示或帮助? 如果我需要使用NodeJS,我该怎么做?

如何使用node-gyp在Mac上生成XCode项目

我正在使用node-gyp来构buildnode.js加载项。 binding.gyp文件的内容是 { 'targets': [ { 'target_name': 'myapp', 'include_dirs': ['api-sdk'], 'sources': [ 'main.cpp', 'lib.cpp'], 'cflags!': [ '-fno-exceptions' ], 'cflags_cc!': [ '-fno-exceptions' ], 'conditions': [ ['OS=="mac"', { 'xcode_settings': { 'GCC_ENABLE_CPP_EXCEPTIONS': 'YES' } }] ] } ] } 在Windows上,当我运行node-gyp configure ,Visual Studio项目会自动生成。 但在Mac上,在执行node-gyp configure gyp configure之后不会生成相应的XCode项目。 有谁知道如何用Node-gyp生成XCode项目? 我应该添加一些设置到binding.gyp文件? 谢谢, 杰弗里

在iOS设备上执行本地部署停留在运行1个自定义shell脚本之一

我正在尝试在iOS设备上运行React Native应用程序。 它在模拟器上工作正常,但在设备上运行需要长达20-25分钟的时间。 我遇到了运行1个自定义shell脚本之一。 我尝试删除npm,清除守望者,重置npmcaching,更新React版本,守望者版本等,但没有任何工作。 我甚至尝试使用命令部署到设备,即使这花费了很多时间。 附上截图供参考。

ios-deploy无法在Mac OS X El Capitan 10.11上安装

我正尝试通过运行sudo npm install -g ios-deploy ios-deploy在Mac OS X El Capitan 10.11上sudo npm install -g ios-deploy并且它以这个错误信息结束: sh: line 1: 1106 Abort trap: 6 xcodebuild npm ERR! Darwin 15.0.0 npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "ios-deploy" npm ERR! node v4.2.3 npm ERR! npm v2.14.7 npm ERR! code ELIFECYCLE npm ERR! ios-deploy@1.8.3 preinstall: `./src/check_reqs.js && xcodebuild` npm […]

以编程方式在Cordova插件中添加IOSfunction

我为Cordova IOS开发了一个插件,用于使用应用程序组。 该插件需要激活XCode中的目标 – >function下的应用程序组function,然后select其中一个应用程序组。 如果我手动激活它,它运作良好,但我想以编程方式激活它,以及在plugin.xml中,或与自定义的钩子。 有人实现了?

xcode使用错误的node.js版本

我是React Native的新手。 我使用了react-native init XXX来创build一个新的项目。 当启动xcodeproj,我得到一个错误说: const setupEnvScript = /^win/.test(process.platform) ^^^^^ SyntaxError: Use of const in strict mode. at Module._compile (module.js:439:25) at Module._extensions..js (module.js:474:10) at Object.require.extensions.(anonymous function) [as .js] (/Users/allanhahaha/Documents/Seat/getseat/SeatApp/node_modules/react-native/node_modules/babel-core/lib/api/register/node.js:214:7) at Module.load (module.js:356:32) at Function.Module._load (module.js:312:12) at Module.require (module.js:364:17) at require (module.js:380:17) at Object.<anonymous> (/Users/allanhahaha/Documents/Seat/getseat/SeatApp/node_modules/react-native/cli.js:15:18) at Module._compile (module.js:456:26) at Object.Module._extensions..js (module.js:474:10) 根据我的研究,这是一个node.js版本问题:我应该使用v4.0 +。 我正在使用NVM来pipe理我的node.js版本。 在常规的terminal窗口中 […]