Articles of yarnpkg

我怎样才能configurationgit,以便node_modules可以本地版本化,但在推送时忽略?

我怎样才能configurationgit,以便node_modules可以本地版本化,但在推送时忽略? 有没有可能? 为什么:不同的包装系统(例如npm / yarn / ..)访问node_modules ,有时一些包被损坏。 我们想监视,工具是什么改变的。 并且不应将node_modules推送到开发服务器上。

如何用纱线安装私人NPM包?

我需要用纱线安装我公司的私人npm软件包 – 我该怎么做? 我设置了npmloginauthentication令牌,但它并没有帮助 – 私人npm包总是以404错误等找不到错误 yarn add @private/my-private-pacakge 不起作用,但是这个npm命令起作用: npm install @private/my-private-package 工程 – 我试图设置纱configurationregistry/身份validation令牌,但注意到帮助。 错误: Error: https://registry.npmjs.org/@private/my-private-package/-/my-private-package-0.0.5.tgz: Request failed "404 Not Found" at Request.res (/…./………/.yarn/updates/0.18.1/lib/fetchers/tarball-fetcher.js:231:20)

如何使用下载的纱线依赖关系

这可能是一个非常愚蠢的问题,但如果你能帮助我的话,那将是非常棒的。 这是问题:我已经添加了一个包到我的项目。 它包含一些我想在我的HTML文件中使用的CSS文件等。 我已经使用yarn add <package>添加了它。 这些文件位于/node_modules/semantic-ui-css/semantic.min.css 。 我必须引用完整的node_modulepath来加载我的HTML文件中的CSS文件? 这听起来不对。 在我使用包pipe理器之前,我只是下载了一些css文件,将它们放到/vendor/css/并使用它们。 或者现在正常使用<link rel="stylesheet" type="text/css" href="node_modules/semantic-ui-css/semantic.min.css"> ?

为什么纱线在版本正确的时候会说“find不兼容的模块”?

当我运行yarn ,我收到以下错误: yarn install v0.16.1 [1/4] Resolving packages… [2/4] Fetching packages… error recursive-iterator@2.0.1: The engine "node" is incompatible with this module. Expected version ">=6.0.0". error Found incompatible module info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. 但是,我已经安装的Node版本是v6.9.2-pre ,这对于版本范围似乎是正确的。 任何想法,为什么我得到这个错误?

jhipster不被识别为内部或外部命令,可操作程序或batch file

我跟着这里https://jhipster.github.io/installation/和JHipster快速启动,但在我的Windows 10上,我已经得到了“jioster不被识别为内部或外部的命令,可操作的程序或batch file”还有,我试过键入“yo jhipster”,就是这样的 D:\ CODE \ jHipster> yo jhipster错误jhipster 你似乎没有安装名为“jijster”的发电机。 但是,帮助正在进行中: 你可以通过npmsearchyeoman-generator或通过http://yeoman.io/generators/查看可用的生成器。 用npm install generator-jhipster安装它们。 看到你所有安装的发电机运行哟没有任何参数。 添加–help选项也会显示子生成器。 如果哟找不到发生器,请运行哟医生来排除系统故障。 现在对Windows的剂量jijster支持? 我已经在2016年之前使用过它,并且运行良好,但是现在它不能像文档所说的那样工作。 文件是正确的吗?

通过YARN添加generator-jhipster时出错

我运行以下命令通过纱线安装generator-jhipster: yarn global add generator-jhipster 这样做后,我遇到了以下问题: The engine "node" is incompatible with this module. Expected version ">=6.9.5" 任何线索,我怎么能解决这个问题? TIA

有没有人能够复制纱(包pipe理器)声称性能?

上个星期我和一位朋友共进午餐,那位朋友自称是真棒纱,它的速度比npm快得多。 作为一个花费太多时间观看npm进度条的人,我只是使用我已有的项目进行比较。 https://yarnpkg.com/en/compare 在所有情况下,我先删除了node_modules文件夹。 我想纱线需要caching的机会,所以我第一次运行yarn install约7米10秒。 第二轮(我确实看到几乎没有时间)花了5分20秒。 跳回到npm已经有这些依赖关系cachef它花了差不多两分钟来运行npm install 。 所以我的结果与纱自己的比较页完全相反。 我是如何比较这些东西有什么深刻的缺陷? 这里是我的testing中安装的依赖关系: "angular": "^1.5.8", "angular-animate": "^1.5.8", "angular-i18n": "^1.5.8", "angular-moment": "^1.0.0", "babel-core": "^6.3.26", "babel-loader": "^6.2.0", "babel-plugin-transform-es2015-block-scoping": "^6.10.1", "babel-preset-es2015": "^6.3.13", "babel-preset-react": "^6.3.13", "bootstrap-datetimepicker": "0.0.7", "clean-webpack-plugin": "^0.1.14", "css-loader": "^0.23.1", "deep-freeze": "0.0.1", "del": "^1.1.1", "delorean": "^0.9.7", "es6-promise": "^3.0.2", "highcharts": "^5.0.0", "immutable": "^3.7.6", "jquery": "^2.1.4", "json-loader": "^0.5.4", "moment": "^2.10.6", […]

使用`yarn add`安装的NPM依赖关系在`package.json`中有`+ deprecated`后缀

我正在考虑完全迁移到纱线,但我想我不完全理解它是如何工作的。 为什么会发生这种情况的具体原因? 我试着用yarn add phantomjs –dev –exact但是我的package.json上的列表说: "devDependencies": { "phantomjs": "2.1.7+deprecated" } 这个+deprecated后缀是什么意思? 这将继续与npm install正常npm install在未来的工作?

npm更新取消链接链接的包

我有一个项目,其中包含一个根节点包,其中包含由npm链接在一起的子包 – 这些子包相互依赖(列在package.json依赖项中),结构基本如下所示: -rootpackage –subpackageA –subpackageB 假设subpackageA依赖于subpackageB,所以我把它们链接起来,避免在subpackageB的源代码发生变化之后,在subpackageA中发布/重新安装subpackageB。 链接工作得很好,直到我运行npm update subpackageA,导致子包B被取消链接。 现在,我看到两个选项: 我理论上可以在每次npm install或npm update后运行npm link操作,以确保链接始终存在。 这在postinstall的情况下适用于postinstall ,但是在更新的情况下,不postinstall 。 我不知道更新后会调用npm的任何postupdate命令。 也许有一种方法可以更聪明地做到这一点,也许用纱线 ,我也使用,在某种程度上,它可以防止取消链接或排除我的子包的更新,所以我不会失去我的子包之间的链接,但现在我不知道这样的方式。 有没有办法使这些选项之一工作或任何其他方式来解决这个问题? 我需要保持这个和其他的链接,所以我们不必在每次安装/更新后运行npm link 。 我无法在任何地方真的find关于这个问题的信息。 顺便说一句我正在使用节点6.4.0和NPM 3.10.3。

如何将项目迁移到扁平化模式?

我们有一个相当全面的倚仗项目,有许多依赖,用纱线pipe理。 现在我们想将其转换为纱线平面模式,但纱线想要将所有依赖转换为平面模式,并要求使用版本的几十个依赖关系。 有时这很简单,就像在1.0.2和1.0.4之间select一样。 但也有我需要在0.0.3,1.0.19和2.2.1之间进行select的情况,以及我将要select的任何版本,有些事情会中断。 由于纱线总是转换整个项目和所有的依赖关系,所以debugging困难的版本select实际上会破坏整个应用程序是相当复杂的事实。 这在lodash 3和4中尤其是问题。lodash在版本4中改变了模块结构,所以两个主要版本都是不兼容的。 不幸的是,在一个普通的应用程序的应用程序有很多的包依赖于lodash 3或lodash 4,他们都没有工作,因为各自的其他依赖项被打破。 有没有办法在“混合”模式下进行迁移,其中一些依赖关系是平坦的,有些则不是? 通过这种方式,我可以将单个软件包迁移到平面模式并testing应用程序,运行规格等,然后继续下一个软件包。 此外,我非常感谢任何有助于解决lodash问题的build议。