NodeJS – 为什么节点报告错误的版本..?

我正在运行Windows 7专业版,并有节点v4.2.2

我刚刚访问过https://nodejs.org/en/并下载了“node-v6.10.1-x64.msi”以升级到v6.10.1 (目前的LTS)。

我安装了这个并重新启动了我的机器,但是现在在命令行上运行node -v返回v0.10.40

我检查了我的系统PATHvariables,它有C:\Program Files\nodejs\ 。 当我查看C:\Program Files\nodejs\node.exe的属性时,在“详细信息”选项卡上显示“产品版本”为6.10.1

为什么当我更新到v6.10.1 ..时, node -v reporting v0.10.40

       

网上收集的解决方案 "NodeJS – 为什么节点报告错误的版本..?"

我安装了Atom,它有自己的节点版本安装在:

C:\Program Files\Atom\resources\app\apm\bin

这里的v0.10.40v0.10.40

此path位于系统PATHvariables列表中的C:\Program Files\nodejs\之前,因此执行node -v ,会在C:\Program Files\nodejs\中的版本之前findAtom版本。

手动将C:\Program Files\nodejs\放在系统PATHvariables列表中,然后重新启动命令提示符将其解决。

node -v现在报告v6.10.1