npm使用预发布版本进行安装

我想在我的package.json中使用pre-release版本来获得最新版本(包含als预发行版本)的一些依赖项,但由于某些原因,它不适用于我的情况。 预发布完全被忽略。 作为一个例子让我们使用angular度。 如果我问"angular": ">=1.4.0-rc.0 <1.4.1"作为依赖项,我会希望我会得到版本1.4.0-rc.2安装,但我得到的版本1.4.0

npm info angular显示,有一些rc版本可用


'1.4.0-beta.4',
'1.4.0-beta.5',
'1.4.0-beta.6',
'1.4.0-rc.0',
'1.4.0-RC.1',
'1.4.0-rc.2',

我的package.json看起来如下

 "dependencies": { "angular": ">=1.4.0-rc.0 <1.4.1" } 

任何想法,为什么我没有得到任何RC版本? 我必须做些什么才能使它工作?

       

网上收集的解决方案 "npm使用预发布版本进行安装"

这似乎是合乎逻辑的,版本的顺序通常如下(对于angular色版本1.4.x):

  1. 1.4.0-beta.0
  2. 1.4.0-beta.2
  3. 1.4.0-beta.3
  4. 1.4.0-beta.4
  5. 1.4.0-beta.5
  6. 1.4.0-beta.6
  7. 1.4.0-rc.0
  8. 1.4.0-RC.1
  9. 1.4.0-rc.2
  10. 1.4.0
  11. 1.4.1

如果你要求"angular": ">=1.4.0-rc.0 <1.4.1" ,那么1.4.1不太严格的最新版本是1.4.0

无论如何,如果你要求"angular": ">=1.4.0-rc.0 <1.4.0" ,最新版本将是1.4.0-rc.2